Universal 5411 - SailNet Community
LinkBack Thread Tools
post #1 of 3 Old 05-12-2009 Thread Starter
Junior Member
Join Date: May 2009
Posts: 1
Thanks: 0
Thanked 0 Times in 0 Posts
Rep Power: 0
Universal 5411

After 2 years of trouble free use, my 1981 27' Catalina with the Universal 5411 diesel is having a problem. The engine starts well and will rev up. When I throtle back and put the prop in gear the engine will not reach full power. It seems to run at about 1/3 to 1/2 power made only 4 MPH from ramp to marina and took 5 minutes to get to that speed. What do I need to do?

I bleed the fuel system. At the injector one line (closest to front) was delivering a pulse of fuel. Rear line was delivering a steady stream. All else seems to be OK. Some fuel could be 2 years (or more old) Stabilizer was added 07 and 08 winter.

gbertelsen is offline  
Quote Quick Reply Share with Facebook
Sponsored Links
post #2 of 3 Old 05-12-2009
Senior Member
JimsCAL's Avatar
Join Date: May 2007
Location: Glen Cove, NY
Posts: 3,028
Thanks: 2
Thanked 88 Times in 82 Posts
Rep Power: 9
If the engine runs, bleeding the fuel system is not necessary. Since the issue seems to be you are down on power, my list of possible problems would include: plugged fuel filter(s), bad fuel, and bad injectors (rebuild or replace).
JimsCAL is offline  
Quote Quick Reply Share with Facebook
post #3 of 3 Old 05-12-2009
Irrationally Exuberant
Join Date: Jul 2007
Location: Northern Virginia
Posts: 1,339
Thanks: 9
Thanked 6 Times in 6 Posts
Rep Power: 9
Or prop could be badly fouled.

Tom K

2000 Beneteau 331
Northern Chesapeake Bay

Ambition is a poor excuse for not having enough sense to be lazy ~ Steven Wright
arf145 is offline  
Quote Quick Reply Share with Facebook

Quick Reply

By choosing to post the reply above you agree to the rules you agreed to when joining Sailnet.
Click Here to view those rules.

Register Now

In order to be able to post messages on the SailNet Community forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
Please note: After entering 3 characters a list of Usernames already in use will appear and the list will disappear once a valid Username is entered.

User Name:
Please enter a password for your user account. Note that passwords are case-sensitive.


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:


Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.

Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page

Similar Threads
Thread Thread Starter Forum Replies Last Post
water leaking in oil - Universal Diesel 5411 stef9 Gear & Maintenance 21 11-24-2013 02:55 AM
Overheating Universal 5411 JohnBassett Gear & Maintenance 20 05-20-2009 12:54 PM
Universal 5411 exhaust elbow cooltec Gear & Maintenance 2 06-25-2007 07:20 PM
Universal 5411 Fuel System cooltec Gear & Maintenance 4 08-17-2006 01:28 PM
Universal diesel 5411 rmiille Gear & Maintenance 1 12-30-2001 07:01 AM

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On
Trackbacks are On
Pingbacks are On
Refbacks are On

For the best viewing experience please update your browser to Google Chrome