Control cable replacement - SailNet Community
 
LinkBack Thread Tools
post #1 of 3 Old 08-09-2009 Thread Starter
"Sparkie"
 
j34035's Avatar
 
Join Date: Nov 2006
Location: Jackson, Missouri
Posts: 343
Thanks: 1
Thanked 1 Time in 1 Post
Rep Power: 10
 
Control cable replacement

I have had really stiff shifing for the past several weeks, and it it has gotten worse lately. I pulled the cable out and that is the culprit. It is a Teleflex cable, but there are no legible numbers because it was slightly rubbing where it was mounted and "erased" the part number. I have the standard Edson pedistel steering system with shifting and throttle. Is this cable the type 33 cable I see in several of the online catalogs? It is a 10-32 threaded system, with both ends identical. Has about 3.5" total travel out of the boat. Anybody have experience with this cable? Thanks
DD

Doug
Jboat J/37c (new to me Jan 2011); J/22 #1003


To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
j34035 is offline  
Quote Quick Reply Share with Facebook
Sponsored Links
Advertisement
 
post #2 of 3 Old 08-10-2009
Senior Member
 
patrickrea's Avatar
 
Join Date: Aug 2007
Location: Toronto
Posts: 407
Thanks: 0
Thanked 0 Times in 0 Posts
Rep Power: 9
 
Go to the Edson website. They have the manuals online. Your pedestal uses stand 33 and 64 series cables.

Patrick Rea

To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.

1978 30' Hughes Northstar 1000
1964 20' Bertram Moppie
patrickrea is offline  
Quote Quick Reply Share with Facebook
post #3 of 3 Old 08-10-2009 Thread Starter
"Sparkie"
 
j34035's Avatar
 
Join Date: Nov 2006
Location: Jackson, Missouri
Posts: 343
Thanks: 1
Thanked 1 Time in 1 Post
Rep Power: 10
 
I found it! I had to dig through their on line catalog but it was there. Thanks for the help!!
DD

Doug
Jboat J/37c (new to me Jan 2011); J/22 #1003


To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
j34035 is offline  
Quote Quick Reply Share with Facebook
Reply

Quick Reply
Message:
Options

By choosing to post the reply above you agree to the rules you agreed to when joining Sailnet.
Click Here to view those rules.

Register Now



In order to be able to post messages on the SailNet Community forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
Please note: After entering 3 characters a list of Usernames already in use will appear and the list will disappear once a valid Username is entered.


User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in









Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.




Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page



Similar Threads
Thread Thread Starter Forum Replies Last Post
Installing an anchor windlass GoodOldBoat Good Old Boat 9 05-23-2015 05:53 PM
Steering Cable Replacement zoom555 Gear & Maintenance 26 06-03-2008 04:20 PM

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome