Installing Avon tow rings - SailNet Community

   Search Sailnet:

 forums  store  


Quick Menu
Forums           
Articles          
Galleries        
Boat Reviews  
Classifieds     
Search SailNet 
Boat Search (new)

Shop the
SailNet Store
Anchor Locker
Boatbuilding & Repair
Charts
Clothing
Electrical
Electronics
Engine
Hatches and Portlights
Interior And Galley
Maintenance
Marine Electronics
Navigation
Other Items
Plumbing and Pumps
Rigging
Safety
Sailing Hardware
Trailer & Watersports
Clearance Items

Advertise Here






Go Back   SailNet Community > On Board > Gear & Maintenance
 Not a Member? 
  #1  
Old 01-20-2003
Junior Member
 
Join Date: Sep 2002
Posts: 4
Thanks: 0
Thanked 0 Times in 0 Posts
Rep Power: 0
robmccarthy is on a distinguished road
Installing Avon tow rings

I have been trying to install tow rings onto my avon (hypalon). Used 1 part (perhaps the problem) patch cement that came with the repair kit at west marine- recommended by staff. Followed instuctions meticulously but after drying I can pull them right off with a good tug. Re-did it a second time to ensure no error- same result. Any ideas about a more effective product or other advice?
thanks
Rob
Reply With Quote Share with Facebook
  #2  
Old 01-20-2003
Senior Member
 
Join Date: Mar 2002
Posts: 306
Thanks: 0
Thanked 0 Times in 0 Posts
Rep Power: 13
Sailmc is on a distinguished road
Installing Avon tow rings

There are two things you need to check. First, make sure you have the right adhesive. There are two seperate adhesives for PVC and Hypalon. Avon is Hypalon so you need to make sure you have the right one. Second you need to thoroughly scrub the area with acetone. If you have used any type of treatment on the boat previously such as a silicone treatment you may have a tough time getting anything to stick.
Reply With Quote Share with Facebook
  #3  
Old 01-21-2003
Member
 
Join Date: Jul 2000
Posts: 64
Thanks: 0
Thanked 0 Times in 0 Posts
Rep Power: 15
clayton is on a distinguished road
Installing Avon tow rings

I installed tow rings on my Avon several years ago. If my memory serves me, I ordered a special cement from Avon. They have stayed on with no movement in all towing conditions.
Good Luck.
Reply With Quote Share with Facebook
Reply


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools

 
Posting Rules
You may post new threads
You may post replies
You may post attachments
You may edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On


Similar Threads
Thread Thread Starter Forum Replies Last Post
Avon RIB Repair FalconEddie Gear & Maintenance 12 03-11-2005 07:43 AM
installing a backstay adjuster chris1514 Racing 1 08-19-2003 09:01 AM
Avon hypalon lifespan grumol Gear & Maintenance 1 11-21-2002 10:04 AM
Installing a Brass keel shoe Joshuadawn Gear & Maintenance 3 11-13-2002 04:50 PM
Installing An Autopilot KIKO Gear & Maintenance 3 03-13-2002 03:06 AM


All times are GMT -4. The time now is 07:44 AM.

Add to My Yahoo!         
Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
SEO by vBSEO 3.6.1
(c) Marine.com LLC 2000-2012

The SailNet.com store is owned and operated by a company independent of the SailNet.com forum. You are now leaving the SailNet forum. Click OK to continue or Cancel to return to the SailNet forum.