Volvo Model 2003 Hot Water Connection - SailNet Community
 
LinkBack Thread Tools
post #1 of 5 Old 03-13-2010 Thread Starter
Junior Member
 
Join Date: Mar 2010
Posts: 7
Thanks: 0
Thanked 0 Times in 0 Posts
Rep Power: 0
 
Volvo Model 2003 Hot Water Connection

I have a 1987 Volvo Model 2003 engine. I'd like to connect a hot water system to the "fresh water" side of the engine. Ther do not appear to be any connections on the fresh water cooling system to easily tap into. Does anyone have experience connecting a hot water system to the fresh water side of this engine?

Thanks
Allegro1 is offline  
Quote Quick Reply Share with Facebook
Sponsored Links
Advertisement
 
post #2 of 5 Old 03-13-2010
Courtney the Dancer
 
jrd22's Avatar
 
Join Date: Nov 2000
Location: San Juan Islands., WA, USA
Posts: 3,885
Thanks: 4
Thanked 22 Times in 21 Posts
Rep Power: 15
 
I have two Volvo's (I know, I know, lucky me ) and both have outlets for coolant ( for a hot water heater, bus type heater, etc). I would strongly recommend calling your local Volvo dealer, they should be able to email or fax a diagram of your engine indicating which are the ports to use. My local dealer, Coastal Marine in Seattle has done this several times for me. Better than hoping to get it right from advice here on the forum.

John
SV Laurie Anne

1988 Brewer 40 Pilothouse

jrd22 is offline  
Quote Quick Reply Share with Facebook
post #3 of 5 Old 03-15-2010
Junior Member
 
Join Date: Mar 2010
Posts: 11
Thanks: 0
Thanked 0 Times in 0 Posts
Rep Power: 0
 
I have Volvo's install manual for the 2002 and it shows the connectons.
I can send you a pdf file of that page.
kcford is offline  
Quote Quick Reply Share with Facebook
post #4 of 5 Old 03-16-2010
Junior Member
 
Join Date: Mar 2010
Posts: 11
Thanks: 0
Thanked 0 Times in 0 Posts
Rep Power: 0
 
OOPS. You said a 2003. My manual covers 2003 motor also.
kcford is offline  
Quote Quick Reply Share with Facebook
post #5 of 5 Old 03-17-2010 Thread Starter
Junior Member
 
Join Date: Mar 2010
Posts: 7
Thanks: 0
Thanked 0 Times in 0 Posts
Rep Power: 0
 
Thanks - I just got the shop manual from Volvo. I'll see how that goes!
Allegro1 is offline  
Quote Quick Reply Share with Facebook
Reply

Quick Reply
Message:
Options

By choosing to post the reply above you agree to the rules you agreed to when joining Sailnet.
Click Here to view those rules.

Register Now



In order to be able to post messages on the SailNet Community forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
Please note: After entering 3 characters a list of Usernames already in use will appear and the list will disappear once a valid Username is entered.


User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in









Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.




Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page



Similar Threads
Thread Thread Starter Forum Replies Last Post
MacGregor 26 vs. ? jiml2p Boat Review and Purchase Forum 207 06-22-2015 03:38 PM
Hot Water Heater Replacement sailthechesapke Gear & Maintenance 2 04-09-2013 11:46 AM
Making hot water walt123 General Discussion (sailing related) 2 03-09-2002 05:34 PM
Water Ballast/Manufacturer RSJ Boat Review and Purchase Forum 6 03-07-2002 05:59 PM
Volvo 2001 Water Heater pmccann Cruising & Liveaboard Forum 1 03-02-2001 03:22 AM

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome