SailNet Community

SailNet Community (http://www.sailnet.com/forums/)
-   Gear & Maintenance (http://www.sailnet.com/forums/gear-maintenance/)
-   -   xantrex freedom marine 1500 inverter/charger issues (http://www.sailnet.com/forums/gear-maintenance/63680-xantrex-freedom-marine-1500-inverter-charger-issues.html)

ncstatesailor 04-09-2010 05:51 PM

xantrex freedom marine 1500 inverter/charger issues
 
I am currently living on a 34ft Morgan that is equipped with a great little xantrex freedom marine 1500 inverter/charger. The two battery banks that are currently lead acid type.. are at the end of their lifespan and I have purchased two AGM batteries to replace them. I see in the user manual for the inverter that I should be able to hold down the 'invert' button for five seconds.. and then press the charge button... in order to see/select which battery type the unit is set to charge. I need to change it to AGM, but when I hold down the buttons.. nothing on the display changes.

I am wondering if I can not select the battery type until I disconnect the current batteries? I just wanted to make sure my unit's buttons are responsive before I go disconnecting everything.

Does anyone else have any experience with installing these units/ know of any problems with the two buttons on the front?

Thanks!

sailingdog 04-09-2010 06:57 PM

If the batteries are dead, then the inverter/charger may not work properly. IIRC, it will have issues if connected to dead batteries. That is probably why the display isn't working. I'd point out that AGM and Wet Cell batteries are pretty close, so that you can probably hook up the new batteries fairly safely, and then change the settings once the new batteries are online.


All times are GMT -4. The time now is 12:46 PM.

Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
SEO by vBSEO 3.6.1
(c) Marine.com LLC 2000-2012