Victron BMV 600 - Issues Installing - SailNet Community
 
LinkBack Thread Tools
post #1 of 3 Old 07-12-2010 Thread Starter
Catalina 270
 
Join Date: Jul 2010
Posts: 8
Thanks: 0
Thanked 0 Times in 0 Posts
Rep Power: 0
 
Victron BMV 600 - Issues Installing

Hey folks,

Has anyone had any issues installing the Victron BMV600? It seemed pretty straight forward, but I'm not getting any power to the actual monitor from the shunt. Just a blank screen.

I have checked all the connections, compared them to the manual and had a friend double check my work. The fuse on the "power" cable to the shunt is fine.

Am I missing something really obvious? I believe it's just supposed to turn on once connected to power although the instruction manual leaves something to be desired.

Thanks for any help,

Mike
mkeller23173 is offline  
Quote Quick Reply Share with Facebook
Sponsored Links
Advertisement
 
post #2 of 3 Old 07-12-2010
Senior Member
 
trantor12020's Avatar
 
Join Date: Mar 2006
Location: Singapore
Posts: 700
Thanks: 4
Thanked 10 Times in 10 Posts
Rep Power: 10
 
You might want to run through the wiring and compare against the drawings and check off each wire. Make sure you install it EXACTLY as the wiring diagram intended. Some time there seems a compromise can be made because electrically it don't make a difference, well sometime it do makes a difference and one don't see it. I've a LinkLite and had no problem getting it to work. Of course I did exactly what the diagram shows. Maybe you got a faulty set? Good luck.

Ken
2002 Hunter 326, SV Millennium 2
1999 Macgregor 26X, SV Millennium
trantor12020 is offline  
Quote Quick Reply Share with Facebook
post #3 of 3 Old 07-14-2010 Thread Starter
Catalina 270
 
Join Date: Jul 2010
Posts: 8
Thanks: 0
Thanked 0 Times in 0 Posts
Rep Power: 0
 
Hey Ken, problem solved. Bad fuse. Looked absolutely fine by the naked eye, but when you put it through a multimeter, it's no good. Bypassed the fuse and all worked as expected. Thanks.
mkeller23173 is offline  
Quote Quick Reply Share with Facebook
Reply

Quick Reply
Message:
Options

By choosing to post the reply above you agree to the rules you agreed to when joining Sailnet.
Click Here to view those rules.

Register Now



In order to be able to post messages on the SailNet Community forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
Please note: After entering 3 characters a list of Usernames already in use will appear and the list will disappear once a valid Username is entered.


User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in









Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.




Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page



Similar Threads
Thread Thread Starter Forum Replies Last Post
VICTRON BMV 600 Battery meter BELLATRIX1965 Electrical Systems 3 11-07-2009 10:11 PM

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome