Head Problem - SailNet Community

   Search Sailnet:

 forums  store  


Quick Menu
Forums           
Articles          
Galleries        
Boat Reviews  
Classifieds     
Search SailNet 
Boat Search (new)

Shop the
SailNet Store
Anchor Locker
Boatbuilding & Repair
Charts
Clothing
Electrical
Electronics
Engine
Hatches and Portlights
Interior And Galley
Maintenance
Marine Electronics
Navigation
Other Items
Plumbing and Pumps
Rigging
Safety
Sailing Hardware
Trailer & Watersports
Clearance Items

Advertise Here






Go Back   SailNet Community > On Board > Gear & Maintenance
 Not a Member? 
  #1  
Old 04-21-2003
Junior Member
 
Join Date: Sep 2001
Posts: 11
Thanks: 0
Thanked 0 Times in 0 Posts
Rep Power: 0
bjoc2314 is on a distinguished road
Head Problem

We bought a 2001 Catalina 310 near the end of last season so this was our first launch. The head, which worked fine in the fall, is not pumping in seawater, I have the thru-hull valve open and the head in "wet bowl" mode, but nothing happens. "Dry bowl" mode seems to work fine.

I suspest the problem is the Wet/dry bowl switch/valve. Any suggestions on a solution or cause of the problem would be apprecaiated. Thank you

Brian O''Connor
Catalina 310 #151
Anam na Mara
NY, NY
Reply With Quote Share with Facebook
  #2  
Old 04-21-2003
Junior Member
 
Join Date: Sep 2001
Posts: 11
Thanks: 0
Thanked 0 Times in 0 Posts
Rep Power: 0
bjoc2314 is on a distinguished road
Head Problem

???
Reply With Quote Share with Facebook
  #3  
Old 04-22-2003
Senior Nappy Headed Ho
 
Join Date: Feb 2001
Posts: 734
Thanks: 0
Thanked 0 Times in 0 Posts
Rep Power: 0
Denr is an unknown quantity at this point
Head Problem

If you did not winterize the head properly, that is to say by pouring Auntie Freeze not only in the bowl and pumped through the line to the holding tank but as well by pouring Auntie Freeze on the intake side of the pump, you could have damaged the pump assembly. Do not fear your MSD my son, you can rebuild it with a simple kit. It may save your butt some day. Pun intended!
Reply With Quote Share with Facebook
  #4  
Old 04-23-2003
Member
 
Join Date: Nov 2002
Posts: 84
Thanks: 0
Thanked 0 Times in 0 Posts
Rep Power: 12
h37skipper is on a distinguished road
Head Problem

Easy to check. Remove the inlet hose at the head. Open the thru-hull or, if it is too far away, have someone open it. If water comes out of the hose then the valve is bad. My guess is that the hose, thru-hull, or seacock is clogged. You should have a filter on that hose, right after the seacock or whatever kind of valve you are using.
Reply With Quote Share with Facebook
Reply


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools

 
Posting Rules
You may post new threads
You may post replies
You may post attachments
You may edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On


Similar Threads
Thread Thread Starter Forum Replies Last Post
Control Head fix for Merriman Steering System tdp Gear & Maintenance 1 06-09-2011 03:00 PM
What''s the best toilet (head) and... Myblueheaven Cruising & Liveaboard Forum 2 10-04-2003 09:52 AM
Head installation Irwin32 Gear & Maintenance 4 03-20-2003 12:23 PM
Rudder head corrosion aflanigan Gear & Maintenance 3 01-27-2003 01:01 AM
Head Problems bootsy1962 General Discussion (sailing related) 3 02-19-2002 07:26 PM


All times are GMT -4. The time now is 03:12 AM.

Add to My Yahoo!         
Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
SEO by vBSEO 3.6.1
(c) Marine.com LLC 2000-2012

The SailNet.com store is owned and operated by a company independent of the SailNet.com forum. You are now leaving the SailNet forum. Click OK to continue or Cancel to return to the SailNet forum.