broken westerbeke engine mounts in 331 - SailNet Community

   Search Sailnet:

 forums  store  


Quick Menu
Forums           
Articles          
Galleries        
Boat Reviews  
Classifieds     
Search SailNet 
Boat Search (new)

Shop the
SailNet Store
Anchor Locker
Boatbuilding & Repair
Charts
Clothing
Electrical
Electronics
Engine
Hatches and Portlights
Interior And Galley
Maintenance
Marine Electronics
Navigation
Other Items
Plumbing and Pumps
Rigging
Safety
Sailing Hardware
Trailer & Watersports
Clearance Items

Advertise Here






Go Back   SailNet Community > On Board > Gear & Maintenance
 Not a Member? 
  #1  
Old 08-30-2010
Junior Member
 
Join Date: Aug 2010
Location: michigan
Posts: 1
Thanks: 0
Thanked 0 Times in 0 Posts
Rep Power: 0
finney is on a distinguished road
Unhappy broken westerbeke engine mounts in 331

Hi all we have a Westerbeke 30b in our 331. Last year while traveling the front port side monting bolts broke off where the attach the leg bracket to the front of the eng. Did the repair had the allignment checked and started a new year. This year the leg on the same side broke where the bend it to match it to the front of the engine. Westerbeke has been NO help and treated me like dirt because its out of warranty coverage. ( The folks at Mack Boring Yanmar were much nicer and offered a lot of suggestions great place.)

Has anyone out there had simular problems? the yard wants to make a steel bridge and weld the two front mounts together. I'm not sure if that won't jsut transfer what ever force is causing the problem to send its energy to a new place and cause more problems. Westerbeke has redesigned the mounts with a gussett welded behind the point where mine broke which leads me to think they knew it was weak. Any thought would be welcome hope to find anyone with the same problem to talk over the issue
Reply With Quote Share with Facebook
  #2  
Old 01-29-2013
nmejicano's Avatar
Capt Nery
 
Join Date: Sep 2012
Location: South Florida
Posts: 26
Thanks: 0
Thanked 0 Times in 0 Posts
Rep Power: 0
nmejicano is on a distinguished road
Re: broken westerbeke engine mounts in 331

I just found a rear starboard side mount broken (at least one of the bolts). I have a 2004 Westerbeke B3 and as soon as I haul out in three weeks I wilkl replace all four since the other three are pretty much rusted. The replacement mounts from Westerbeke are over $200.00 each! I found a company, Torresen Marine, Inc which makes mounts for this engine for $48.00! You also can see how to change them through a great video that you will find at: www.pbase.com/mainecruising/motor_mounts. Good luck. By the way it is better to rep[lace all four instead of just one if they are more than two-three years old.
Reply With Quote Share with Facebook
Reply


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools

 
Posting Rules
You may post new threads
You may post replies
You may post attachments
You may edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On


Similar Threads
Thread Thread Starter Forum Replies Last Post
Yanmar engine mounts keep failing 3JH4E flyingfishUK Announcements and Suggestions Box 6 07-21-2011 03:01 PM
Attaching engine mounts Waltthesalt Diesel 2 08-26-2010 01:06 AM


All times are GMT -4. The time now is 04:16 AM.

Add to My Yahoo!         
Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
SEO by vBSEO 3.6.1
(c) Marine.com LLC 2000-2012