SailNet Community

SailNet Community (http://www.sailnet.com/forums/)
-   Gear & Maintenance (http://www.sailnet.com/forums/gear-maintenance/)
-   -   Engine Oil Pressure Problem (http://www.sailnet.com/forums/gear-maintenance/768-engine-oil-pressure-problem.html)

msamelso 02-15-2001 04:23 PM

Engine Oil Pressure Problem
 
I have a strange oil pressure problem.

At low to moderate idle, the oil pressure light comes on. As I increase throttle (whether in gear or neutral), the light goes off.

I have checked my Nigel Calder book - but can''t seem to find a possible problem.

Has anyone had this problem before?

M. Samelson

yachtkeljen 02-20-2001 04:53 AM

Engine Oil Pressure Problem
 
There could be a few problems
1st drain the oil made put new oil as per manufactures spec as well as new oil filter Test again but let the engine run for awhile?????? if the oil pressure alarm/light stays off then you cold have diesel fuel contamination smell the old old before you dispose of it is it very thin and does it smell of diesel there could have been a leaking fuel injector which diluted the oil
2 The problem of lights coming on could also be ..... Has the engine idling revs been lowered Check manufactures spect it should idle at about 900 rpm with all the axullaries ie feed pumps refrigeration pump and alternator on maybe the engine is idling to slow
3 There could be a problem with the sender unit
I had the same problem with my engine a 55 hp Yannma diesel checked all of the above (engine is about 4 yrs old) so I added PROLONG oil additive as a prventive measure it sure helped the oil pressure

jrd22 02-20-2001 07:25 PM

Engine Oil Pressure Problem
 
It''s probably just the sender unit, or too low an idle speed. Get an actual mechanical guage and find out what pressure the light is coming on at. Fairly simple to do, ask for instructions for your particular engine at the dealer or repair shop. You didn''t say how long you have had it or how long it has been doing this. If you have had it for years and it just started it may be low pressure caused by wear/damage. It could also be that you have a cooling problem, if the coolant is too hot the oil can thin causing lower oil pressure especially at idle after running hard. Check coolant level if FW cooled and water pump/belt. Also check raw water filter. John


All times are GMT -4. The time now is 04:31 PM.

Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
SEO by vBSEO 3.6.1
(c) Marine.com LLC 2000-2012