My bottom is showing - SailNet Community
LinkBack Thread Tools
post #1 of 2 Old 03-14-2012 Thread Starter
me at 67!
deniseO30's Avatar
Join Date: Nov 2006
Location: Bristol pa
Posts: 6,988
Thanks: 55
Thanked 127 Times in 116 Posts
Rep Power: 10
Red face My bottom is showing

because we didn't put the bottom paint on right away when we did the barrier coat, there are areas of the bottom where the ablative is flaking off. As I'm not in the mood to make myself look like Smurfette all over again. I'll scrape.. then... sand with 100 grit? Or look for somekind of epoxy primer? It seems to stay on the boat when it's wet, and only flakes off when it's power washed.

Good news; Barrier coat is very intact! No blisters after almost 3 years!

Denise, Bristol PA, Oday 30. On Tidal Delaware River, Anchor Yacht Club.
To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.

To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.

My last project!
To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.

My boat is sold!
deniseO30 is offline  
Quote Quick Reply Share with Facebook
Sponsored Links
post #2 of 2 Old 03-15-2012
Senior Member
Lake Superior Sailor's Avatar
Join Date: Aug 2011
Location: Eagle River Wi.
Posts: 1,019
Thanks: 0
Thanked 11 Times in 11 Posts
Rep Power: 5
Re: My bottom is showing

I had this same problem on my boat only I felt it was from mixing brands. Plan to sand mine with 100 Grit sandpaper, coat with a coat of barrier Pittit brand, & finish with Pittit brand Antifouling. Last fall the bottom looked great when I pulled it. After I powerwashed all the blue ran off.Hope this works for me, cause its expensive product & time consuming.
I want to get in the water by the 15th May as I am planning a trip to Isle Royal...Dale

Reluctant Lady
Cal 28, 1967
Lake Superior
Where God got it done!
Lake Superior Sailor is offline  
Quote Quick Reply Share with Facebook

Quick Reply

By choosing to post the reply above you agree to the rules you agreed to when joining Sailnet.
Click Here to view those rules.

Register Now

In order to be able to post messages on the SailNet Community forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
Please note: After entering 3 characters a list of Usernames already in use will appear and the list will disappear once a valid Username is entered.

User Name:
Please enter a password for your user account. Note that passwords are case-sensitive.


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:


Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.

Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page

Similar Threads
Thread Thread Starter Forum Replies Last Post
Battery showing charging when no charge applied labatt Gear & Maintenance 6 04-18-2009 01:57 AM
Leading edge of my rudder is showing its age ChicagoNewport27 Gear & Maintenance 14 04-22-2007 11:18 PM
Showing off the ship (The State) NewsReader News Feeds 0 07-23-2006 04:15 AM

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On
Trackbacks are On
Pingbacks are On
Refbacks are On

For the best viewing experience please update your browser to Google Chrome