_ _ _ ... _ _ _ - SailNet Community
 
LinkBack Thread Tools
post #1 of 4 Old 04-28-2008 Thread Starter
It's 5 O'clock somewhere
 
kccollbran's Avatar
 
Join Date: Mar 2008
Posts: 49
Thanks: 0
Thanked 0 Times in 0 Posts
Rep Power: 0
 
_ _ _ ... _ _ _

S.O.S.

I need a Mexican liability insurance policy NOW!

I've had more friggin' trouble with insurance companies this past week. The agent I was using, told me today that they no longer provide coverage for vessels older than 1970, mine is 1960. I have a new survey, the boat is in great shape, new rigging, new motor and the list goes on.

Who has a good agent, that doesn't discriminate due to a boats age?????

Need it NOW!

Kevin
kccollbran is offline  
Quote Quick Reply Share with Facebook
Sponsored Links
Advertisement
 
post #2 of 4 Old 04-28-2008
Senior Member
 
artbyjody's Avatar
 
Join Date: Jan 2008
Location: Bellingham, PNW
Posts: 3,146
Thanks: 0
Thanked 1 Time in 1 Post
Rep Power: 11
       
Use BoatUS - they are about the only non hassle insurance for 20+ yr boats. They can provide the Mexican rider.

-- Jody

S/V "
To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
" -
1983, Barberis Show 38! or
To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.



To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.







artbyjody is offline  
Quote Quick Reply Share with Facebook
post #3 of 4 Old 04-28-2008
Senior Member
 
Join Date: Jun 2005
Location: New Orleans
Posts: 1,989
Thanks: 8
Thanked 35 Times in 32 Posts
Rep Power: 10
 
uh, not to pick nits here, but isn't it "... _ _ _ ..."?


I think you sent "O-S-O"
nolatom is offline  
Quote Quick Reply Share with Facebook
post #4 of 4 Old 04-28-2008 Thread Starter
It's 5 O'clock somewhere
 
kccollbran's Avatar
 
Join Date: Mar 2008
Posts: 49
Thanks: 0
Thanked 0 Times in 0 Posts
Rep Power: 0
 
Oh S#!t

Quote:
Originally Posted by nolatom View Post
uh, not to pick nits here, but isn't it "... _ _ _ ..."?


I think you sent "O-S-O"
No wonder no one answered? got your attention though, didn't it
kccollbran is offline  
Quote Quick Reply Share with Facebook
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the SailNet Community forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
Please note: After entering 3 characters a list of Usernames already in use will appear and the list will disappear once a valid Username is entered.


User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in









Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.




Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome