Westerbeke 27 Electrical Issue - SailNet Community

   Search Sailnet:

 forums  store  


Quick Menu
Forums           
Articles          
Galleries        
Boat Reviews  
Classifieds     
Search SailNet 
Boat Search (new)

Shop the
SailNet Store
Anchor Locker
Boatbuilding & Repair
Charts
Clothing
Electrical
Electronics
Engine
Hatches and Portlights
Interior And Galley
Maintenance
Marine Electronics
Navigation
Other Items
Plumbing and Pumps
Rigging
Safety
Sailing Hardware
Trailer & Watersports
Clearance Items

Advertise Here






Go Back   SailNet Community > General Interest > General Discussion (sailing related)
 Not a Member? 


Reply
 
LinkBack Thread Tools
  #1  
Old 08-09-2012
Junior Member
 
Join Date: Aug 2012
Posts: 1
Thanks: 0
Thanked 0 Times in 0 Posts
Rep Power: 0
SailNetUser12 is on a distinguished road
Red face Westerbeke 27 Electrical Issue

My 1983 W 27 Starts but trips its own 20 A circuit breaker on mounted on negine & won't restart, cannot diagnose fault yet...any leads?
Reply With Quote Share with Facebook
  #2  
Old 08-09-2012
Maine Sail's Avatar
Senior Member
 
Join Date: Jan 2003
Location: Maine Coast
Posts: 5,247
Thanks: 9
Thanked 107 Times in 78 Posts
Rep Power: 15
Maine Sail is just really nice Maine Sail is just really nice Maine Sail is just really nice Maine Sail is just really nice
Re: Westerbeke 27 Electrical Issue

Quote:
Originally Posted by SailNetUser12 View Post
My 1983 W 27 Starts but trips its own 20 A circuit breaker on mounted on negine & won't restart, cannot diagnose fault yet...any leads?
Check all the wiring for chafe. You may have a short to ground somewhere..
__________________
______
-Maine Sail / CS-36T


To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.




© Images In Posts Property of Compass Marine Inc.


Reply With Quote Share with Facebook
Reply


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools

 
Posting Rules
You may post new threads
You may post replies
You may post attachments
You may edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On


Similar Threads
Thread Thread Starter Forum Replies Last Post
Westerbeke 63C coloradoblue Gear & Maintenance 0 07-19-2012 06:09 PM
22 hp westerbeke nolasailor Diesel 1 01-07-2011 05:59 AM
Westerbeke 71 HP Rseaman Diesel 1 12-09-2010 09:35 AM
Mysterious electrical issue garymcg Gear & Maintenance 12 09-23-2008 03:06 PM
Diagnosing/solving electrical outlet issue jmunson2 Gear & Maintenance 55 06-02-2007 04:43 PM


All times are GMT -4. The time now is 09:43 AM.

Add to My Yahoo!         
Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
SEO by vBSEO 3.6.1
(c) Marine.com LLC 2000-2012