Westerbeke 27 Electrical Issue - SailNet Community
 
LinkBack Thread Tools
post #1 of 2 Old 08-09-2012 Thread Starter
Junior Member
 
Join Date: Aug 2012
Posts: 1
Thanks: 0
Thanked 0 Times in 0 Posts
Rep Power: 0
 
Red face Westerbeke 27 Electrical Issue

My 1983 W 27 Starts but trips its own 20 A circuit breaker on mounted on negine & won't restart, cannot diagnose fault yet...any leads?
SailNetUser12 is offline  
Quote Quick Reply Share with Facebook
Sponsored Links
Advertisement
 
post #2 of 2 Old 08-09-2012
Senior Member
 
Maine Sail's Avatar
 
Join Date: Jan 2003
Location: Maine Coast
Posts: 5,887
Thanks: 20
Thanked 222 Times in 169 Posts
Rep Power: 16
       
Re: Westerbeke 27 Electrical Issue

Quote:
Originally Posted by SailNetUser12 View Post
My 1983 W 27 Starts but trips its own 20 A circuit breaker on mounted on negine & won't restart, cannot diagnose fault yet...any leads?
Check all the wiring for chafe. You may have a short to ground somewhere..

______
-Maine Sail / CS-36T


To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.




Images In Posts Property of Compass Marine Inc.


Maine Sail is offline  
Quote Quick Reply Share with Facebook
Reply

Quick Reply
Message:
Options

By choosing to post the reply above you agree to the rules you agreed to when joining Sailnet.
Click Here to view those rules.

Register Now



In order to be able to post messages on the SailNet Community forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
Please note: After entering 3 characters a list of Usernames already in use will appear and the list will disappear once a valid Username is entered.


User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in









Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.




Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page



Similar Threads
Thread Thread Starter Forum Replies Last Post
Westerbeke 63C coloradoblue Gear & Maintenance 0 07-19-2012 06:09 PM
22 hp westerbeke nolasailor Diesel 1 01-07-2011 05:59 AM
Westerbeke 71 HP Rseaman Diesel 1 12-09-2010 09:35 AM
Mysterious electrical issue garymcg Gear & Maintenance 12 09-23-2008 03:06 PM
Diagnosing/solving electrical outlet issue jmunson2 Gear & Maintenance 55 06-02-2007 04:43 PM

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome