help with Merc 3.9 outboard... - SailNet Community

   Search Sailnet:

 forums  store  


Quick Menu
Forums           
Articles          
Galleries        
Boat Reviews  
Classifieds     
Search SailNet 
Boat Search (new)

Shop the
SailNet Store
Anchor Locker
Boatbuilding & Repair
Charts
Clothing
Electrical
Electronics
Engine
Hatches and Portlights
Interior And Galley
Maintenance
Marine Electronics
Navigation
Other Items
Plumbing and Pumps
Rigging
Safety
Sailing Hardware
Trailer & Watersports
Clearance Items

Advertise Here






Go Back   SailNet Community > Welcome to Sailnet > Introduce Yourself
 Not a Member? 

Introduce Yourself Welcome to the Sailnet.com - The world's largest online sailing community! Tell us about yourself so we can get to know you. NEW!


Reply
 
LinkBack Thread Tools
  #1  
Old 09-28-2011
Junior Member
 
Join Date: Mar 2011
Location: PA,USA
Posts: 3
Thanks: 0
Thanked 0 Times in 0 Posts
Rep Power: 0
elborba is on a distinguished road
help with Merc 3.9 outboard...

Hi gang...Elborba here, first post, so i hope i am doing it right.
I own a Catalina 22 from 1974, hull# 3066. I am in the middle of a major rebuild on this boat. (me and the missus call her "Wild On 3"). I recently purchased an Mercury 3.9,circa 1966ish. It runs pretty good, but there don't seem to be any pee stream coming out of it anywhere to indicate if it is getting any water circulation. Cant find any info on this motor. I was hoping one of you might have a little experience with this vintage? Any input would be much appreciated!
Reply With Quote Share with Facebook
Reply


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools

 
Posting Rules
You may post new threads
You may post replies
You may post attachments
You may edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On


Similar Threads
Thread Thread Starter Forum Replies Last Post
Can't engage pull start on 1988 Merc 5hp outboard foxglove Gear & Maintenance 4 10-09-2010 01:51 AM
Old merc outboard stuck... blueranger Gear & Maintenance 0 08-10-2009 09:51 PM
Poorly Running 9.9 Merc Outboard SpeedAgent Gear & Maintenance 17 04-18-2009 10:21 PM
Is it possible to update / convert a Merc outboard??? MABON01 Gear & Maintenance 4 09-03-2008 01:59 AM
Merc outboard won't idle JewelledJester Gear & Maintenance 4 05-21-2008 02:32 PM


All times are GMT -4. The time now is 12:54 AM.

Add to My Yahoo!         
Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
SEO by vBSEO 3.6.1
(c) Marine.com LLC 2000-2012

The SailNet.com store is owned and operated by a company independent of the SailNet.com forum. You are now leaving the SailNet forum. Click OK to continue or Cancel to return to the SailNet forum.