help with Merc 3.9 outboard... - SailNet Community
Introduce Yourself Welcome to the Sailnet.com - The world's largest online sailing community! Tell us about yourself so we can get to know you.

 
LinkBack Thread Tools
post #1 of 1 Old 09-28-2011 Thread Starter
Junior Member
 
Join Date: Mar 2011
Location: PA,USA
Posts: 3
Thanks: 0
Thanked 0 Times in 0 Posts
Rep Power: 0
 
help with Merc 3.9 outboard...

Hi gang...Elborba here, first post, so i hope i am doing it right.
I own a Catalina 22 from 1974, hull# 3066. I am in the middle of a major rebuild on this boat. (me and the missus call her "Wild On 3"). I recently purchased an Mercury 3.9,circa 1966ish. It runs pretty good, but there don't seem to be any pee stream coming out of it anywhere to indicate if it is getting any water circulation. Cant find any info on this motor. I was hoping one of you might have a little experience with this vintage? Any input would be much appreciated!
elborba is offline  
Quote Quick Reply Share with Facebook
Reply

Quick Reply
Message:
Options

By choosing to post the reply above you agree to the rules you agreed to when joining Sailnet.
Click Here to view those rules.

Register Now



In order to be able to post messages on the SailNet Community forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
Please note: After entering 3 characters a list of Usernames already in use will appear and the list will disappear once a valid Username is entered.


User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in









Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.




Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page



Similar Threads
Thread Thread Starter Forum Replies Last Post
Can't engage pull start on 1988 Merc 5hp outboard foxglove Gear & Maintenance 4 10-09-2010 01:51 AM
Old merc outboard stuck... blueranger Gear & Maintenance 0 08-10-2009 09:51 PM
Poorly Running 9.9 Merc Outboard SpeedAgent Gear & Maintenance 17 04-18-2009 10:21 PM
Is it possible to update / convert a Merc outboard??? MABON01 Gear & Maintenance 4 09-03-2008 01:59 AM
Merc outboard won't idle JewelledJester Gear & Maintenance 4 05-21-2008 02:32 PM

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome