SailNet Community

SailNet Community (http://www.sailnet.com/forums/)
-   Island Packet (http://www.sailnet.com/forums/island-packet/)
-   -   Failed manual bilge pump (http://www.sailnet.com/forums/island-packet/126993-failed-manual-bilge-pump.html)

motogon 03-10-2014 12:24 PM

Failed manual bilge pump
 
1 Attachment(s)
Manual bilge pump failed on my "new" 1983 IP26 exactly like on this picture. I searched on Kempax pumps but no results. Any recommendation on replacement pump and source of this type stuff online?

Thanks,

chuckbauer 03-20-2014 10:35 PM

Re: Failed manual bilge pump
 
Andrew, had the same pump on my IP 26 MK II which also failed. I could find no direct replacement so went with something like a Whale Compac 50.
No at the boat until this weekend so not sure of exact model. It fit ok except the bolt holes were different so had to do a little filling/patching.

It is mounted on the starboard side of the cockpit maybe a foot forward of the locker.

Defender has them. If I run across the paper work I'll post the exact mode.

Good luck.

Chuck Bauer
Etude, IP 26 MK II Hull 78

stam22 09-01-2014 06:36 AM

Re: Failed manual bilge pump
 
Don't bother trying to rebuild it. It's junk. I bought a rebuild kit from RARITAN, they had all the parts. It lasted about two weeks and failed again. There's a reason that they (Kempax) are out of business.

rhpike 09-04-2014 11:41 AM

Re: Failed manual bilge pump
 
Whale manual bilge pumps are what IP installs these days, as well as most boat manufacturers. Much better reliability.

stam22 09-26-2014 12:47 AM

Re: Failed manual bilge pump
 
I agree that you can't beat Whale pumps. After a little further research into Kempax, I read that they were used on Halberg-Rassy yachts, so how bad could they really be. I also discovered that Kempax was bought out by Johnson pumps in Sweden, and that they were still making the same pump, only difference is now they are black, not white. This made me think, maybe I had missed something in the rebuild, so I conducted an autopsy on the pump and found that I had missed a hairline crack on the cleanout cover around the threads. This was soon remedied with some JB weld. I am in the process of ordering a new cover from Hamilton Marine, as Johnson doesn't sell direct. I'll post an update if this works.


All times are GMT -4. The time now is 08:41 AM.

Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
SEO by vBSEO 3.6.1
(c) Marine.com LLC 2000-2012