SailNet Community - Reply to Topic

   Search Sailnet:

 forums  store  


Quick Menu
Forums           
Articles          
Galleries        
Boat Reviews  
Classifieds     
Search SailNet 
Boat Search (new)

Shop the
SailNet Store
Anchor Locker
Boatbuilding & Repair
Charts
Clothing
Electrical
Electronics
Engine
Hatches and Portlights
Interior And Galley
Maintenance
Marine Electronics
Navigation
Other Items
Plumbing and Pumps
Rigging
Safety
Sailing Hardware
Trailer & Watersports
Clearance Items

Advertise Here






Go Back   SailNet Community > General Interest > General Discussion (sailing related) > Did I kill my battery?
 Not a Member? 


Thread: Did I kill my battery? Reply to Thread
Title:
  

By choosing to post the reply below you agree to the rules you agreed to when joining Sailnet.
Click Here to view those rules.

Message:
Trackback:
Send Trackbacks to (Separate multiple URLs with spaces) :
Post Icons
You may choose an icon for your message from the following list:
 

Register Now

In order to be able to post messages on the SailNet Community forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
Please note: After entering 3 characters a list of Usernames already in use will appear and the list will disappear once a valid Username is entered.
User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Click here to view the posting rules you are bound to when clicking the
'Submit Reply' button below


Additional Options
Miscellaneous Options

Click here to view the posting rules you are bound to when clicking the
'Submit Reply' button below


Topic Review (Newest First)
03-14-2013 04:54 PM
TQA
Re: Did I kill my battery?

Quote:
Originally Posted by rhr1956 View Post
Honey, did you turn the lights off? My reply was yes. The problem I discovered two days later was, no I had not turned the lights off. The battery was dead as hell. It did show 5.4 volts. I have it on the smart charger now. Do you think I kiilled it or will it recover? It is an AGM battery.
If it accepts the charge and gets back to about 12.8 volts after charging and the float voltage has dissipated put it back into service.

However will almost certainly have lost a little of it's capacity and will die a little sooner.
03-14-2013 11:07 AM
blutoyz
Re: Did I kill my battery?

I can say that when HD went to AGM batteries on their bikes a complete discharge destroyed the batteries(yes...plural...don't ask). Charge it fully and watch the performance for a while to be safe.
03-14-2013 10:09 AM
mad_machine
Re: Did I kill my battery?

letting a battery drain or even a couple of times will not kill it.. on a regular lead acid battery, it will cause sulferacation.. not so sure on an AGM.

But think about it.. how many times have people completely drained car batteries with little to no issues other than needing a jump to get the car started right afterwards?
03-14-2013 09:31 AM
chucklesR
Re: Did I kill my battery?

The LVD above is okay for a low amp single circuit.
For a starter circuit, or the entire boat you can expect to spend more.
Here's a link to a series of LVD's that will protect starter circuits/batteries and the entire boat (200amp for example).
Battery-Related Products | Low Voltage Disconnect Switches48510 | Cole Hersee - Littelfuse

The cost a bit more than a tenner. They protect more than a single switch on the panel being forgotten.

The advantage is you'll never wake up in the morning and not have the juice to crank the engine, or drive 2 hours to your boat for a beautiful day of sailing and then spend two hours charging a dead lump of plastic lead and acid.

Here's one with a price listed - 130 amp capable, 263 bucks
http://www.tessco.com/products/displ...55&eventPage=1
03-14-2013 03:26 AM
nasali
Re: Did I kill my battery?

You should take more care your battery, nor you will kill your battery.
03-14-2013 03:24 AM
nasali
Re: Did I kill my battery?

Maintenance is very simple, to reduce the depth of discharge.
03-14-2013 12:15 AM
mergens
Re: Did I kill my battery?

Nice looking piece of kit and only a tenner! Sign me up.
03-13-2013 06:24 PM
FinallySailing
Re: Did I kill my battery?

Quote:
Originally Posted by rhr1956 View Post
Where is a good source to get a low voltage cutoff switch? How does it get wired in?
I've recently got one of these to install before my boat vent :



Got it for a tenner (sterling, that is) on Fleebay. They are sold under the name "Brocott" or "Kemo" battery guard or Kemo M148A.

You can adjust the cut off voltage on the small yellow potentiometer knob. Installation is easy - Wire it between your battery (and fuse) and your load (max 20Amp if you install it on a heatsink).
03-13-2013 05:32 PM
rhr1956
Re: Did I kill my battery?

Where is a good source to get a low voltage cutoff switch? How does it get wired in?
03-13-2013 05:00 PM
chucklesR
Re: Did I kill my battery?

5.4v?
well, yeah, dead.
You should have a low voltage cut off at 10.2 to save the beast.

You may be able to recharge it, if so make sure you get a good, FULL charge on.
This thread has more than 10 replies. Click here to review the whole thread.

 
Posting Rules
You may post new threads
You may post replies
You may post attachments
You may edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On


All times are GMT -4. The time now is 05:00 PM.

Add to My Yahoo!         
Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
SEO by vBSEO 3.6.1
(c) Marine.com LLC 2000-2012

The SailNet.com store is owned and operated by a company independent of the SailNet.com forum. You are now leaving the SailNet forum. Click OK to continue or Cancel to return to the SailNet forum.