SailNet Community - Reply to Topic
Thread: Mermaid AC Question Reply to Thread
Send Trackbacks to (Separate multiple URLs with spaces) :
Post Icons
You may choose an icon for your message from the following list:

Register Now

In order to be able to post messages on the SailNet Community forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
Please note: After entering 3 characters a list of Usernames already in use will appear and the list will disappear once a valid Username is entered.

User Name:
Please enter a password for your user account. Note that passwords are case-sensitive.


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:


Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.

  Additional Options
Miscellaneous Options

Click here to view the posting rules you are bound to when clicking the
'Submit Reply' button below

  Topic Review (Newest First)
05-24-2013 04:01 PM
Tim R.
Re: Mermaid AC Question

Open the control box and tap on the different relays. Often it is a bad relay or a lose tab on one of them. I have experienced both of these failures on my Mermaid unit and the symptoms were the same.

You can use any thermostat that has a fan control and heat/ac switch on them. Pretty cheap at Home Depot. Maybe $30.
05-24-2013 03:52 PM
Re: Mermaid AC Question

I have a unit that I am just about to ebay. WHere are you
For Sale: Mermaid 16500 BTU ac/ heater - Cruisers & Sailing Forums
04-30-2013 11:48 PM
Mermaid AC Question

Go to and buy his ebook - about $20. He will help you diagnose your ac problems via email. I found his advice to be really valuable and saved at least two visits by the ac repairman. He responds pretty quickly also.
04-30-2013 10:57 PM
last mango
Mermaid AC Question

AC unit - Mermaid - at times it's cooling and then it quits. Fan runs and cycles. Water flow is steady out the side of the boat. How do you tell if the compressor is kicking on along with the fan. Have my suspicions it's not. Has a programmable thermostat and you can turn it down manually and sometimes it takes and sometimes it doesn't. Makes me wonder if that is some of this issue. Can you put a plain jane household unit to one of these? The overload reset is fine. Does not appear to be it. Just seems to come and go. Not sure if the coils should feel cold,warm. You don't seem to hear anything but the fan - no cycling in and out that I can tell, Just looking for obvious ideas. Have not had the boat very long and not sure where to look. Has worked off and on. Any ideas appreciated

Last Mango
Endeavour 38
Mobile AL

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On

For the best viewing experience please update your browser to Google Chrome