SailNet Community - Reply to Topic

   Search Sailnet:

 forums  store  


Quick Menu
Forums           
Articles          
Galleries        
Boat Reviews  
Classifieds     
Search SailNet 
Boat Search (new)

Shop the
SailNet Store
Anchor Locker
Boatbuilding & Repair
Charts
Clothing
Electrical
Electronics
Engine
Hatches and Portlights
Interior And Galley
Maintenance
Marine Electronics
Navigation
Other Items
Plumbing and Pumps
Rigging
Safety
Sailing Hardware
Trailer & Watersports
Clearance Items

Advertise Here






Go Back   SailNet Community > Boat Builders Row > Sabre > Sabre 30 fresh water problem
 Not a Member? 


Thread: Sabre 30 fresh water problem Reply to Thread
Title:
  

By choosing to post the reply below you agree to the rules you agreed to when joining Sailnet.
Click Here to view those rules.

Message:
Trackback:
Send Trackbacks to (Separate multiple URLs with spaces) :
Post Icons
You may choose an icon for your message from the following list:
 

Register Now

In order to be able to post messages on the SailNet Community forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
Please note: After entering 3 characters a list of Usernames already in use will appear and the list will disappear once a valid Username is entered.
User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Click here to view the posting rules you are bound to when clicking the
'Submit Reply' button below


Additional Options
Miscellaneous Options

Click here to view the posting rules you are bound to when clicking the
'Submit Reply' button below


Topic Review (Newest First)
08-25-2007 10:43 PM
camaraderie My guess is that you:
1. Have an air lock in the line and the pump needs to be primed OR
2. The pump motor is running but the head needs a rebuild since it is not developing suction. This is easy to test just by removing the hose at the pump inlet and testing for suction.
08-25-2007 05:58 PM
dolce06
Sabre 30 fresh water problem

My 1981 30 has a fresh water delivery issue; I get water at the foot pump in the head but not at the sink, sink in the galley, or footpump in the galley. The head works fine. The pump is running with no water coming or going. I have a standard port side tank and 2 bladders to starboard. The bladders are currently out and the hoses are not stopped. The port side tank is full and the switch is set to "port". I've only had the boat 18 months and in the past we have done over nighters so I've never really used the system. In addition, I used a marina last winter and paid them to winterize. Could it be a they threw a valve somewhere? I have looked everywhere to see if there is one closed to no avail. The owners manual doesn't cover much with the exception of a layout and instructions to use antifreeze (suitable for consumption) coming winter. Does anyone have any idea what could the problem? Is is the bladders breaking the loop by chance? Or is the a valve somewhere that I am missing. We are leaving for a week and I'd love to get it operating.
Thanks in advance for any input.
Jeff

 
Posting Rules
You may post new threads
You may post replies
You may post attachments
You may edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On


All times are GMT -4. The time now is 09:14 AM.

Add to My Yahoo!         
Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
SEO by vBSEO 3.6.1
(c) Marine.com LLC 2000-2012

The SailNet.com store is owned and operated by a company independent of the SailNet.com forum. You are now leaving the SailNet forum. Click OK to continue or Cancel to return to the SailNet forum.