SailNet Community - Reply to Topic
Thread: rust on keel Reply to Thread
Send Trackbacks to (Separate multiple URLs with spaces) :
Post Icons
You may choose an icon for your message from the following list:

Register Now

In order to be able to post messages on the SailNet Community forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
Please note: After entering 3 characters a list of Usernames already in use will appear and the list will disappear once a valid Username is entered.

User Name:
Please enter a password for your user account. Note that passwords are case-sensitive.


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:


Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.

  Additional Options
Miscellaneous Options

Click here to view the posting rules you are bound to when clicking the
'Submit Reply' button below

  Topic Review (Newest First)
01-20-2003 03:08 AM
rust on keel

To some extent this depends on the way your boat has been constructed. Assuming that you don''t have an encapsulated keel, the easiest way is to wirebrush the area and remove any loose rust and use something like Ospho or Naval jelly to consolidate the surface oxydation. They you have a couple choices. There are zinc rich epoxies that bond very well to iron. There are also primers such as zinc chromate that also bond very well. Or you can visit the WEST System site and look at thier method of dealing with rusting iron keels.

If you have an encapsulated keel your problem is far more complex and I don''t have the time to answer that one this morning.

01-19-2003 01:38 PM
rust on keel

The leading edge of my fixed keel shows some surface rust - no doubt the result of encountering oyster beds in the Chesapeake. Is there a chemical rust killer/inhibitor that works? After the rust is removed should I seal the leading edge with something before applying bottom paint? Any advice would be appreciated.

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On

For the best viewing experience please update your browser to Google Chrome