SailNet Community - Reply to Topic
Thread: Lewmar opening ports Reply to Thread
Title:
Message:
Trackback:
Send Trackbacks to (Separate multiple URLs with spaces) :
Post Icons
You may choose an icon for your message from the following list:
 

Register Now



In order to be able to post messages on the SailNet Community forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
Please note: After entering 3 characters a list of Usernames already in use will appear and the list will disappear once a valid Username is entered.


User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in









Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



  Additional Options
Miscellaneous Options

Click here to view the posting rules you are bound to when clicking the
'Submit Reply' button below


  Topic Review (Newest First)
08-10-2004 06:34 PM
sailingfool
Lewmar opening ports

Remove the bolts and the outer trim ring, remove all bedding around the outside, and install a new trim ring bedding it and the bolts carefully with silicone. If this doesn''t work, install a replacement window.
07-19-2004 05:59 PM
joub
Lewmar opening ports

Am not familiar with the Lewmar port, but most ports have adjustments to compensate for gasket compression etc. that might lead to leaks.
Look for some way to tighten the hinges at the top of the port i.e reduce the clearance between the window and the gasket, and a way to increase the compression of the latch mechanism which will do te same thing. Both adjustments will allow you to make a tighter seal between the port window/gasket and frame which will usually stop any leaks.

Good luck

Jim
07-19-2004 05:39 AM
capttack
Lewmar opening ports

Here I am again! I have a Catalina 30 with four Lewmar opening ports. All appear to have small drips from the bottom corners. I can''t determine if the leaks are from the rubber gasket, the window itself or the latch that turns into the groove to close the opening port tight.

This has become a liveaboard, so I have to find the leaks. Any ideas out there???

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On

 
For the best viewing experience please update your browser to Google Chrome