SailNet Community - Reply to Topic

   Search Sailnet:

 forums  store  


Quick Menu
Forums           
Articles          
Galleries        
Boat Reviews  
Classifieds     
Search SailNet 
Boat Search (new)

Shop the
SailNet Store
Anchor Locker
Boatbuilding & Repair
Charts
Clothing
Electrical
Electronics
Engine
Hatches and Portlights
Interior And Galley
Maintenance
Marine Electronics
Navigation
Other Items
Plumbing and Pumps
Rigging
Safety
Sailing Hardware
Trailer & Watersports
Clearance Items

Advertise Here






Go Back   SailNet Community > On Board > Gear & Maintenance > West System Pumps.
 Not a Member? 


Thread: West System Pumps. Reply to Thread
Title:
  

By choosing to post the reply below you agree to the rules you agreed to when joining Sailnet.
Click Here to view those rules.

Message:
Trackback:
Send Trackbacks to (Separate multiple URLs with spaces) :
Post Icons
You may choose an icon for your message from the following list:
 

Register Now

In order to be able to post messages on the SailNet Community forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
Please note: After entering 3 characters a list of Usernames already in use will appear and the list will disappear once a valid Username is entered.
User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Click here to view the posting rules you are bound to when clicking the
'Submit Reply' button below


Additional Options
Miscellaneous Options

Click here to view the posting rules you are bound to when clicking the
'Submit Reply' button below


Topic Review (Newest First)
03-03-2009 11:28 AM
JohnRPollard I've had good service from the pumps as well.

My preference is for a no/low-blush epoxy like M.A.S. or System Three.
03-03-2009 11:15 AM
Trickster I have had numerous pumps over the last couple years. they always seem to keep pumping, however over time i always seem to break the plastic collar of the pump when it gets knocked around. Even then they still seem to work. If you are planning on doing smaller batches i would suggest another method (mixing cups or scale) as there always seems to be so much waste with the pumps on smaller jobs
03-03-2009 03:00 AM
sailingdog 5200 is not a replacement for epoxy, and IMHO shouldn't even be used on a boat. 5200 has too strong an adhesion strength for anything that may need to be removed at some point in the future, and you should probably be using 4200 instead.

Epoxy is really a structural material, and should be used to do things like attach stringers to the hull, fill small voids or holes, etc. However, epoxy has one major caveat to it. It must be painted or coated to protect it from UV degradation. Epoxy breaks down under UV...

Quote:
Originally Posted by Suberk View Post
looks like MAS is a little more pricey, but it you don't have to buy thickener for West... so when would i use epoxy as an adhesive, rather than 5200? Any pros, cons?
03-02-2009 10:32 PM
Suberk looks like MAS is a little more pricey, but it you don't have to buy thickener for West... so when would i use epoxy as an adhesive, rather than 5200? Any pros, cons?
03-02-2009 09:59 PM
Quickstep192 I learned a clever trick from the folks at MAS epoxy. When the pump stops working, dunk (not submerge) the container in hot water. It may take a couple of water changes for the heat to permeate the container, but once warmed up, it softens the whole works and voila, the pump works like a champ again.

PS, I'm using MAS F.L.A.G. epoxy because it doesn't need to be thickened for use as glue. I've only had to use the hot water trick once. I've never had it happen with WEST epoxy which is much thinner.
03-02-2009 09:42 PM
Suberk In the hardware store epoxys its always the hardener that won't dose properly. Funny that scottyt have that isssue.

Looks like i can buy a decent amount of West System and it'll hold. I just pictured the pumps would freeze between lay-ups. Sounds like they go for years.
03-02-2009 09:35 PM
scottyt i go against normal beliefs here, i have had too many pumps that did not work right, always the hardener pump. i use measured cups, the normal ones you see everywhere. it is easy enough to add 5 ozs resin, then one oz hardener, then mix real well pour out of cup in to something that will allow the resin to spread out more like a pie pan. the reason i use the pie pan is if you leave the resin in the cup and its a tall column it can heat it self up and start setting faster.

use the pumps but check the calibration by using the measured cups, then pour out in to a thinner layer after mixing
03-02-2009 09:33 PM
dvpamenter I agree fully with scosch having had the same experience for several years. Pumps continue to work great.
03-02-2009 09:26 PM
scosch Sure. Ive had the same pumps for several years. I normally leave them in the cans and they work fine like that up to a point. After more than a year, I have had the epoxy crystallize in the pump. But by pulling (they still sort of worked) solvent (I believe acetone, maybe lacquer thinner, check West for proper solvent) into the pump and letting it sit overnight, then pumping some fresh solvent in until clean, they were back to good as new. Just remember they are calibrated for West epoxy and may not be right for other brands.
03-02-2009 09:17 PM
Suberk
West System Pumps.

Is there any way to store and reuse the West System pumps? I've been using hardware store 'marine grade' epoxy for some time. I'm thinking of taking some advice from SN and getting some West stuff, just thinking about storage and making the most of the purchase.
Had trouble posting my profile pic, a 73' San Juan 21. Will get there.

 
Posting Rules
You may post new threads
You may post replies
You may post attachments
You may edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On


All times are GMT -4. The time now is 09:17 PM.

Add to My Yahoo!         
Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
SEO by vBSEO 3.6.1
(c) Marine.com LLC 2000-2012

The SailNet.com store is owned and operated by a company independent of the SailNet.com forum. You are now leaving the SailNet forum. Click OK to continue or Cancel to return to the SailNet forum.