SailNet Community - Reply to Topic
Thread: Franmar Soy Gel stripper Reply to Thread
Title:
Message:
Trackback:
Send Trackbacks to (Separate multiple URLs with spaces) :
Post Icons
You may choose an icon for your message from the following list:
 

Register Now



In order to be able to post messages on the SailNet Community forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
Please note: After entering 3 characters a list of Usernames already in use will appear and the list will disappear once a valid Username is entered.


User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in









Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



  Additional Options
Miscellaneous Options

  Topic Review (Newest First)
07-13-2009 11:59 PM
cristamd We used Captain John's Boat Brite Soy stripper a month or two ago to take old bottom paint off, and it worked well enough. We did wind up needing to use saran wrap to keep it wet long enough for it to work, and paint it on *really* thick. I'm not sure if the Franmar stuff is the same, but it's probably similar. We let the soy strip sit for 6-10 hours before scraping it, since it didn't work much faster than that.
07-13-2009 10:16 PM
poopdeckpappy
Franmar Soy Gel stripper

Anyone try this stuff, if so, opinions please, I just ordered some on the advice from a refinisher; I have been using Citrus Gel Stripper ( which I like ) but was told soy will cut stripping time in half

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On

 
For the best viewing experience please update your browser to Google Chrome