SailNet Community - Reply to Topic
Thread: Seafrost 12v BD on Sabre 34 MKII Reply to Thread
Send Trackbacks to (Separate multiple URLs with spaces) :
Post Icons
You may choose an icon for your message from the following list:

Register Now

In order to be able to post messages on the SailNet Community forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
Please note: After entering 3 characters a list of Usernames already in use will appear and the list will disappear once a valid Username is entered.

User Name:
Please enter a password for your user account. Note that passwords are case-sensitive.


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:


Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.

  Additional Options
Miscellaneous Options

Click here to view the posting rules you are bound to when clicking the
'Submit Reply' button below

  Topic Review (Newest First)
05-04-2011 12:01 PM
Bene505 I highly recommend the book on refrigeration by Richard Kollmann

05-04-2011 07:22 AM
deniseO30 How many cubic ft is the box? That would be your guide. The plate should be high but still have clearance. Most often the plate is mounted on the wall that would be adjacent to where the compressor lines would route. The compressor is mounted on a plate with the other parts and that section is called a condenser, if air cooled it should have room for some sort of a air circulation.
05-03-2011 10:50 PM
Seafrost 12v BD on Sabre 34 MKII

I have a Sabre 34 MKII and I am looking into installing a Seafrost.

Which wall did you place the plate on?
What size plate did you get?
Where did you place the compressor?

How has the system been for you?

Thanks in advance!

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

For the best viewing experience please update your browser to Google Chrome