SailNet Community - Reply to Topic
Thread: Need Help Fixing A Wilcox Crittenden Head Toilet Reply to Thread
Title:
Message:
Trackback:
Send Trackbacks to (Separate multiple URLs with spaces) :
Post Icons
You may choose an icon for your message from the following list:
 

Register Now



In order to be able to post messages on the SailNet Community forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
Please note: After entering 3 characters a list of Usernames already in use will appear and the list will disappear once a valid Username is entered.


User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in









Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



  Additional Options
Miscellaneous Options

Click here to view the posting rules you are bound to when clicking the
'Submit Reply' button below


  Topic Review (Newest First)
06-12-2011 02:52 PM
adell50 I was able to get her working!

In the end I just started takig things apart, starting with the easiest stuff, and thankfully, found the culprit early.

Apparently, the previous owner had left the thru-hull open on the intake and something that looked like a cross between alien/predator had inhabited and completely blocked the intake tube. After taking it off the head and thoroughly washing it through and reattaching, it works like a charm!

Thanks again for everyone's help
06-02-2011 12:47 PM
adell50 this is simply great information! I will give the suggestions a look and will let the group know my findings! thanks a lot!
05-26-2011 08:47 AM
svsirius It depends which model you have. One trick I have learned over the years is that sometime you have to prime the pump. Disconnect the fresh water feed coming from the pump to the bowl. Pour some water into that line and slowly lift the pump lever drawing water into the pump body. Once you have done that reconnect to toilet and that should do it.
05-25-2011 02:02 PM
Tempest Seaclo Repair Kits

You might need one of these.

Occasionally, after lack of use, I need to do several short rapid pumps to get water flowing.
( priming the pump so to speak)

There's a little rubber gasket around a plastic ring at the end of the plunger that wears out and may not be allowing proper suction.

I had one unscrew itself once..guests kept spinning the handle...does the plunger feel loose?

I purchased the above kit a few years ago and it made a world of difference, worked like a brand new head!
05-25-2011 02:01 PM
jackdale I have had a similar problem on a Jabsco. It was the top valve gasket.
05-25-2011 01:59 PM
Faster
Quote:
Originally Posted by adell50 View Post
I was able to find a manual for my toilet, but it doesnt have any sort of trouble shooting or set up info.

My head just doesn't seem to be drawing sea water when flushing. Beyond making sure the seacock is open and there is a bucket full of water in the head when trying to flush, does anyone know of anything I might be able to do to make her flush?

Many thanks!@
Apologies in advance if this is too simple, but.....

All heads have some form of a 'flush' or 'dry bowl' switch.. are you sure you are trying the head in the 'flush' mode? If you're in the dry bowl mode that's all it will be trying to do... ie pump the bowl contents out of the bowl, and not bring in any flushing water.
05-25-2011 01:57 PM
adell50 sweet!!! many thanks

She looks to be in pretty good shape, but I'd hate to take it comepltely apart if i didnt have to..
05-25-2011 01:50 PM
imiloa Beyond checking the vent to make sure it's not clogged and (the obvious) making sure the tank's not full, you might want to look at Peggie Hall's area on the Sailboatowners.com web site. She is the expert when it comes to all stinky things.
05-25-2011 01:37 PM
adell50
Need Help Fixing A Wilcox Crittenden Head Toilet

I was able to find a manual for my toilet, but it doesnt have any sort of trouble shooting or set up info.

My head just doesn't seem to be drawing sea water when flushing. Beyond making sure the seacock is open and there is a bucket full of water in the head when trying to flush, does anyone know of anything I might be able to do to make her flush?

Many thanks!@

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On

 
For the best viewing experience please update your browser to Google Chrome