SailNet Community - Reply to Topic

   Search Sailnet:

 forums  store  


Quick Menu
Forums           
Articles          
Galleries        
Boat Reviews  
Classifieds     
Search SailNet 
Boat Search (new)

Shop the
SailNet Store
Anchor Locker
Boatbuilding & Repair
Charts
Clothing
Electrical
Electronics
Engine
Hatches and Portlights
Interior And Galley
Maintenance
Marine Electronics
Navigation
Other Items
Plumbing and Pumps
Rigging
Safety
Sailing Hardware
Trailer & Watersports
Clearance Items

Advertise Here






Go Back   SailNet Community > On Board > Gear & Maintenance > Engines > Diesel > volvo penta md2010 won't start
 Not a Member? 

Diesel This is a forum dedicated to diesel engines and their applicable accessories.


Thread: volvo penta md2010 won't start Reply to Thread
Title:
  

By choosing to post the reply below you agree to the rules you agreed to when joining Sailnet.
Click Here to view those rules.

Message:
Trackback:
Send Trackbacks to (Separate multiple URLs with spaces) :
Post Icons
You may choose an icon for your message from the following list:
 

Register Now

In order to be able to post messages on the SailNet Community forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
Please note: After entering 3 characters a list of Usernames already in use will appear and the list will disappear once a valid Username is entered.
User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Click here to view the posting rules you are bound to when clicking the
'Submit Reply' button below


Additional Options
Miscellaneous Options

Click here to view the posting rules you are bound to when clicking the
'Submit Reply' button below


Topic Review (Newest First)
08-03-2012 09:47 AM
Sabre Dan
Re: volvo penta md2010 won't start

I agree with c-wolf's diagnosis, but would add that you might check the connectivity of the ground running from the starter to the engine block, most likely. Remove and inspect the ground terminal, and sand the ngine block where it connects. This may not be the cause, but could be part of the problem.
07-27-2012 05:17 PM
dabnis
Re: volvo penta md2010 won't start

Quote:
Originally Posted by tahoemark View Post
thanks Paul in Truckee. I lived over by Cave Rock for 15 years, now in So CAL. Anyway, wiring harness conveniently plugs into to the bottom of a relay box at the engine end, so not so easy to just run another wire. Wiring harnesses are great...until they fail!

If you have a solonoid between your start key and battery source and it works, it would appear the wire from the start key to the solonoid may be bad. What I had in mind was temporarily running a seperate wire from the solonoid to a seperate switch to battery source to see if that works? If you have Battery from the starting key going directly to the starter, that is a heavy load to be going through a starter switch and the key switch may have bad contacts? You could jump directly from the battery to the starter post in an emergency.
A diagram of your starting system would help.

Paul T
07-27-2012 03:34 PM
tahoemark
Re: volvo penta md2010 won't start

thanks Paul in Truckee. I lived over by Cave Rock for 15 years, now in So CAL. Anyway, wiring harness conveniently plugs into to the bottom of a relay box at the engine end, so not so easy to just run another wire. Wiring harnesses are great...until they fail!
07-26-2012 09:56 PM
dabnis
Re: volvo penta md2010 won't start

Tahoe,

As Bird said, just by-pass the original wiring. If that works there is an intermittent problem somewhere in the harness that you may never find.

Paul T in Truckee
07-26-2012 07:53 PM
tahoemark
Re: volvo penta md2010 won't start

Ron,
I tried to PM you, but I don't have enough posts. I imagine I can reply to your pm if you would like my email and we can correspond directly. Curious, what boat do you have??
Mark
07-26-2012 07:50 PM
tahoemark
Re: volvo penta md2010 won't start

Ron,

Thanks. I'm glad to know someone else had the same problem, I thought I was going nuts. I'd like your help in telling me how you did the separate key to the starter. On the engine end the harness comes up into the relay box, so I can't see how you could wire it there. Did you just wire it to the solenoid? If so that obviously takes the glow plug out of the loop, but I suppose you could just crank for 10seconds or so and it would start. Do I have this right.

Mark
07-26-2012 04:42 PM
birdlives
Re: volvo penta md2010 won't start

I have been having a similar problem, have the same type Volvo harness. The engine starts fine at the dock, runs for an hour or two. Then I turn it off and sail for three hours or less and cannot restart. The next day at the dock the engine starts fine again and later in the day (when warm) it will not.

I checked the leads on the key switch, the relays, the harness, all seem good. It appears to be a connection that when it gets hot expands or something and then does not work..it is driving me nuts.

I even had a Volvo factory mechanic out and he said to find the problem would be absurdly expensive, might take hours.

My solution (and its not a great one) was to do two things. We wired a seperate set of wires from the key switch to the starter (kind of paralleling the Volvo setup) and also installed an on off switch that was essentially a jumper from the the battery direct to the starter. I lose my instrumentation but do not have to be towed ignominiously back to the dock.

Still have no answer to the problem, its a Volvo thing.

Ron
07-26-2012 03:29 PM
tahoemark
Re: volvo penta md2010 won't start

birdlives,

thanks for the ideas. I have not found the problem. At first I thought it was a bad connection at the solenoid. Once I cleaned that up engine worked fine. Then a few days later, stopped working. I recleaned the solenoid connection and it worked again. Then a few days later stopped working. This time cleaning the connection did'nt work. I then went into the lazarette to follow the wiring back to the switch. This boat has a harness from engine to switch, so no loose wires. Everything looked fine. I checked to make sure everything was snug at switch end and that the 16 prong plug was connected firmly, which it was. Then the engine starts?? The engine has now worked several times in a row. What troubles me is there was nothing apparently loose in the wiring. The wires for the ignition swith come right out of the plastic back of the switch and go into the harness. The plug on the harness is like you find on cars where it snaps together. I should also state that this was a fresh water boat for the last 5 years (but is now in salt water for 6 months) there is no corrosion anywhere.
I'm glad engine seems to be working, but I would feel better if I knew I had actually fixed something. Every time I turn the switch I wonder if it will start.
07-25-2012 05:06 PM
birdlives
Re: volvo penta md2010 won't start

Assuming the starter is good and you get nothing it is very likely a bad ground at the battery terminal or the ground the bolts on the engine below the starter.

check sailnet for threads on MD2040 that didnt start.
06-20-2012 09:45 PM
klem
Re: volvo penta md2010 won't start

Yes, a voltmeter is the right way to approach this. Measure the resistance from the battery negative to the engine ground, there shouldn't be any. Once that is good, switch to voltage and put the black lead on ground and progressively move the red lead from the back of the switch to the starter solenoid checking each connection for good voltage (you need to be pressing the start button). You should find a place where there is suddenly little or no voltage. If there is voltage across your starter solenoid and the starter is not spinner, you likely either have a problem with the solenoid or the starter contact.
This thread has more than 10 replies. Click here to review the whole thread.

 
Posting Rules
You may post new threads
You may post replies
You may post attachments
You may edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On


All times are GMT -4. The time now is 11:01 AM.

Add to My Yahoo!         
Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
SEO by vBSEO 3.6.1
(c) Marine.com LLC 2000-2012

The SailNet.com store is owned and operated by a company independent of the SailNet.com forum. You are now leaving the SailNet forum. Click OK to continue or Cancel to return to the SailNet forum.