SailNet Community - Reply to Topic
Thread: Garmin Airmar DST800 no speed reading Reply to Thread
Send Trackbacks to (Separate multiple URLs with spaces) :
Post Icons
You may choose an icon for your message from the following list:

Register Now

In order to be able to post messages on the SailNet Community forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
Please note: After entering 3 characters a list of Usernames already in use will appear and the list will disappear once a valid Username is entered.

User Name:
Please enter a password for your user account. Note that passwords are case-sensitive.


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:


Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.

  Additional Options
Miscellaneous Options

Click here to view the posting rules you are bound to when clicking the
'Submit Reply' button below

  Topic Review (Newest First)
10-22-2012 05:27 PM
Garmin Airmar DST800 no speed reading

I have a Garmin Airmar DST800 triducer, (NMEA 2000 version) and the speed / knotlog function is not working.

The symptom was that over a few months it took longer and longer to start working each time I sailed. Now it's taking a few hours to come to life. It under-reads significantly, although the extent to which it does that gets less over the hours.

I have tried spinning the paddle, and it spins very freely. I added lubricant and it spins even more freely, but still doesn't work for a few hours.

Any idea what can go wrong?

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On

For the best viewing experience please update your browser to Google Chrome