SailNet Community - Reply to Topic
Thread: Xantrex Link 2000 Troubleshooting Reply to Thread
Title:
Message:
Trackback:
Send Trackbacks to (Separate multiple URLs with spaces) :
Post Icons
You may choose an icon for your message from the following list:
 

Register Now



In order to be able to post messages on the SailNet Community forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
Please note: After entering 3 characters a list of Usernames already in use will appear and the list will disappear once a valid Username is entered.


User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in









Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



  Additional Options
Miscellaneous Options

Click here to view the posting rules you are bound to when clicking the
'Submit Reply' button below


  Topic Review (Newest First)
3 Days Ago 11:41 AM
travlin-easy
Re: Xantrex Link 2000 Troubleshooting

You may have to contact the factory for customer service on this one, Marc.

Good luck,

Gary
3 Days Ago 06:54 AM
acetabulaire
Re: Xantrex Link 2000 Troubleshooting

Hello Gary,
Thank you for this help. I did the reset factory this afternoon, my Fonction has been reseted with the default values, but I still have the E12 on my screen... RRRrrrhhhh...! I haven't more ideas...
Thank you
Marc
6 Days Ago 01:27 PM
travlin-easy
Re: Xantrex Link 2000 Troubleshooting

My system is much older than yours, but I was able to locate the reset procedure in the manual:

RESETTING MEMORY TO FACTORY VALUES:
If some portions of the memory have been "corrupted" you should consider resetting to the factory default values and then changing any specific values you need to. This ensures a clean slate" for your new setup.

1) Follow the procedure outlined on the previous page to first reset the microprocessor.

2) Select Battery bank #1 on the LINK 2000 to reset to factory values for Battery #1. To also reset Inverter and Charger functions to factory defaults, be sure that the INVERT and CHARGE LEDs are lit.

3) Press and hold the SETUP button for approximately 10 seconds. After five seconds the SETUP LED will begin to flash slowly—continue to hold until the SETUP LED begins to flash quickly (about three times per second). Release the SETUP button, press and hold the RESET A Hrs button (blue legend under BATTERY #1 button). After holding down the RESET A Hrs button for about five seconds, you should see a 0 (zero) appear in the display momentarily. If you do not see the zero, the meter did not reset and this step must be repeated.

4) Select Battery bank #2 on the LINK 2000 to reset to factory values for Battery #2.

5) Repeat step 3.

6) Reprogram the necessary setup values such as battery type, capacity, ambient temperature, Peukert's exponent, inverter/charger parameters, and so on.

Hope this helps,

Gary
6 Days Ago 11:13 PM
travlin-easy
Re: Xantrex Link 2000 Troubleshooting

No, in my case I found reset instructions in the user manual. I had to hold down on one of the buttons for 5 seconds, then it cycled through the setup procedure. At that point, I had to hold down the amps button until a message came up, asking me to reset. At that point I had to push that button again to initiate the reset procedure. The entire process probably took about 3 minutes to perform. When I go back to the boat I'll dig the manual out and shoot a photo of the reset instructions.

Gary
1 Week Ago 04:45 PM
acetabulaire
Re: Xantrex Link 2000 Troubleshooting

Ok Gary, good thing for you, but unfortunately the master reset didn't work for me. Just to check, how do you proceed to do the reset? Only unplug the ribbon during 30 minutes, isn't it?

Marc
1 Week Ago 11:38 AM
travlin-easy
Re: Xantrex Link 2000 Troubleshooting

I had the same problem, did a master reset and the problem was gone as well. It returned six months later, did another reset and it has been ever since.

Gary
1 Week Ago 06:15 AM
acetabulaire
Re: Xantrex Link 2000 Troubleshooting

Hello, 3 years later, I have the same problem and would happy to know if the half hour reset worked for you...? For me it didn't work. I still have 0v at the screen but 12,15V at the batteries and same voltage at the pin #4 and 5 of the Monitor terminal board. So I don't understand...
Marc
06-19-2013 10:27 PM
erps
Re: Xantrex Link 2000 Troubleshooting

Just curious, did you try a reset prior to this advice? I tried a reset that lasted about 2 minutes and it didn't work. I'll try the half hour reset. It would be really nice to have both batteries monitored again instead of just one.
06-19-2013 02:37 PM
T37Chef excellent
06-19-2013 10:02 AM
yachtingtypes
Re: Xantrex Link 2000 Troubleshooting

The hard reset worked. No blinking errors!
This thread has more than 10 replies. Click here to review the whole thread.

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On

 
For the best viewing experience please update your browser to Google Chrome