SailNet Community - Reply to Topic
Thread: SSB radio reception Reply to Thread
Send Trackbacks to (Separate multiple URLs with spaces) :
Post Icons
You may choose an icon for your message from the following list:

Register Now

In order to be able to post messages on the SailNet Community forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
Please note: After entering 3 characters a list of Usernames already in use will appear and the list will disappear once a valid Username is entered.

User Name:
Please enter a password for your user account. Note that passwords are case-sensitive.


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:


Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.

  Additional Options
Miscellaneous Options

Click here to view the posting rules you are bound to when clicking the
'Submit Reply' button below

  Topic Review (Newest First)
01-29-2002 05:13 PM
SSB radio reception

i have a sea 235r mounted next to my 2000r
and the ssb used to drive the 2000r nuts.
i mounted ferrites in the 2 cables on the 2000r and that solved my problem. they are available from radio shack.
you also might try adding a few ferrites on either wire coming out of the heart voltage regulator
i am sure that this can''t hurt.

where are you located?
01-29-2002 04:50 PM
Bob S
SSB radio reception

Ihave an Icom 710 SSB installed within 2ft. of a Link 2000R battery monitor regulator. The Link appears to be the cause of RF interference that makes the SSB unusable when the engine is running. A Newmar suppressor has been connected to the alternator with no improvement. The RF interference stops if the Link display control panel is disconnected from the terminal strip. It is not possible to relocate either the SSB opr the Link. Has anyone out there any experience in how to solve this problem?

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On

For the best viewing experience please update your browser to Google Chrome