SailNet Community - Reply to Topic

   Search Sailnet:

 forums  store  


Quick Menu
Forums           
Articles          
Galleries        
Boat Reviews  
Classifieds     
Search SailNet 
Boat Search (new)

Shop the
SailNet Store
Anchor Locker
Boatbuilding & Repair
Charts
Clothing
Electrical
Electronics
Engine
Hatches and Portlights
Interior And Galley
Maintenance
Marine Electronics
Navigation
Other Items
Plumbing and Pumps
Rigging
Safety
Sailing Hardware
Trailer & Watersports
Clearance Items

Advertise Here






Go Back   SailNet Community > On Board > Gear & Maintenance > Clogged Marine Head
 Not a Member? 


Thread: Clogged Marine Head Reply to Thread
Title:
  

By choosing to post the reply below you agree to the rules you agreed to when joining Sailnet.
Click Here to view those rules.

Message:
Trackback:
Send Trackbacks to (Separate multiple URLs with spaces) :
Post Icons
You may choose an icon for your message from the following list:
 

Register Now

In order to be able to post messages on the SailNet Community forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
Please note: After entering 3 characters a list of Usernames already in use will appear and the list will disappear once a valid Username is entered.
User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Click here to view the posting rules you are bound to when clicking the
'Submit Reply' button below


Additional Options
Miscellaneous Options

Click here to view the posting rules you are bound to when clicking the
'Submit Reply' button below


Topic Review (Newest First)
03-30-2007 09:18 PM
Duke 7184 The problem may not be the head. It may well be the holding tank. My experience: I had my new to me Catalina 27 for only a few weeks and the head acted up. I could draw water in but the I had difficulty pumping it out. Seemed like back pressure was hold the water in the bowl. Though it had only been a couple of weeks since the last time, I thought it might be the that I needed to empty the holding tank again.

To empty the tank on the 27 I had to access the pump out connectiom located in the bottom of the anchor locker in the bow. I had tied the anchor locker hatch to the life line to keep it open and was on my knees unscrewing the cap on the pump out connectiom when a gusher (of you know what) soiled me from the wast up. I yelled to my friend who was helping me at the pump out station to hose me down NOW. He was laughing so hard he nearly fell into the water.

This is a story we laguh about now, but at the time, it was anything but funny - to me.

Oh, what hapened??? The holding tank vent was plugged. With the vent plugged, waste pumped into the tank was compressing the air inside that released when I oppened the pump out connection.

Check the holding tank vent.
Duke
03-30-2007 07:56 PM
Valiente I'll second the Lavac recommendation. My wife didn't endorse buying the new boat until she saw it. Then she started taking off her jeans so she could flush them down it.

(The preceding joke might be a little "inside" unless you own a Lavac...)
03-30-2007 06:14 PM
TrueBlue Blake-Lavac makes the best marine toilets in the world. Low maintenace (actually no maintenance), ease of use and very effective flushing with no clogging. We have two onboard - since 2 heads are better.

Downside - initial cost of the units and parts, if ever needed, are expensive due to limited distribution from GB.
03-30-2007 05:05 PM
Freesail99 While we're on the subject, who makes the best head ? Manual or electric ?
03-30-2007 04:27 PM
ReverendMike Ian - I know you said 'no problems with hoses or fittings', but I should point out that Hydrochloric acid (even diluted) can corrode even stainless steel. It is great for mineral deposits, and i don't think many head systems have metal exposed to the 'brown water', just be careful about spills. Vinegar is also acidic enough (barely) to work on most mineral deposits, and a lot gentler on metal. (OK, OK you're right, HCl makes things sparkle, just please make sure there's no loose fittings letting it trickle into your bilge....)

Also about the 'brown TP', (sorry but lunch is over) my cruising instructor gave us each a ziploc....
03-30-2007 04:01 PM
ianhlnd Mineral deposits in the hose are a real problem, the hose opening gradually gets smaller and smaller til nothing goes out. Vinegar is good, but a little on the costly side. I like Muriatic acid which is watered down hydrogen chloride. I water it down even more and pump til the entire system is filled. You'll see the reaction with the calcium in the mineral, let set overnight then flush with clean water. I've used this method for over 20 yrs and never had a problem with hoses or fittings.
03-30-2007 02:30 PM
camaraderie Never let it be said thatyou don't have a good head on your shoulders CD!!
03-30-2007 01:18 PM
Cruisingdad Let it never Go without saying:

CAM KNOWS HIS CRAPPER,
AND ITS FLAPPER,
AND TAKES NO LIP FROM WHIPPER-SNAPPERS.

SO IF YOUR HEAD IS CLOGGED,
YOUR MIND IN A FOG,
LISTEN TO CAM AND NOT THE DOG.


HAHA! I am sure SD will have some kind words for me.

- CD
03-30-2007 01:09 PM
camaraderie Ta-daaaaaa....drum roll for Cam calling it right!!! Again!!!
No one ever said I was the Modestrator!!
03-30-2007 11:49 AM
mathislaw1 Thanks for the input.

When I tried plunging the bowl, the water was pushed into the holding tank (therefore no clog existed). So I examined the hand pump more closely and discoverd the seal has cracked, which makes me think that I wasn't getting enough vacuum. I've ordered replacement parts for the pump and hopefully that will work.

Thanks for all the help
I'm new to the forum, but this seems like a great place to get your questions answered.
This thread has more than 10 replies. Click here to review the whole thread.

 
Posting Rules
You may post new threads
You may post replies
You may post attachments
You may edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On


All times are GMT -4. The time now is 04:25 PM.

Add to My Yahoo!         
Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
SEO by vBSEO 3.6.1
(c) Marine.com LLC 2000-2012

The SailNet.com store is owned and operated by a company independent of the SailNet.com forum. You are now leaving the SailNet forum. Click OK to continue or Cancel to return to the SailNet forum.