SailNet Community - Reply to Topic
Thread: Help with Johnson 4hp carb Reply to Thread
Send Trackbacks to (Separate multiple URLs with spaces) :
Post Icons
You may choose an icon for your message from the following list:

Register Now

In order to be able to post messages on the SailNet Community forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
Please note: After entering 3 characters a list of Usernames already in use will appear and the list will disappear once a valid Username is entered.

User Name:
Please enter a password for your user account. Note that passwords are case-sensitive.


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:


Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.

  Additional Options
Miscellaneous Options

Click here to view the posting rules you are bound to when clicking the
'Submit Reply' button below

  Topic Review (Newest First)
02-06-2014 02:58 PM
Re: Help with Johnson 4hp carb

i have the same problem ,if somebody manage to fix it pls post the answer for others from this community.
01-04-2012 12:25 PM
Originally Posted by robinhood007 View Post
thx for posting the thread I also have the same problem
is there any repair shops in North America?
There are lots of repair shops that specialize in older outboards. The best one in Maryland used to be located on Ritchie Highway, but I haven't been down that highway for years, so I'm not sure if they are still in business.

The other one I knew of was previously known as Imperial Marine on U.S. Route 40 in White Marsh, MD. They had an incredible service department until a few years ago, and they had a service manager who really knows older outboards. When they sold out to Marine Max he retired, but they may still work on these older engines.


01-04-2012 03:48 AM
robinhood007 Hi
thx for posting the thread I also have the same problem
is there any repair shops in North America?
01-04-2012 03:34 AM
JedNeck Is it a choke?
01-04-2012 12:14 AM
PaulinVictoria It's the equivalent of the big red button in K.I.T.T.
01-03-2012 11:45 PM

Hmmm, so i am missing a piece in the throttke linkage...

Maybe i can use it like the PO did


Does anyone know EXACTLY which piece(s) i am missing?

Going to try and post better pics....

Thank you
01-01-2012 12:52 PM
travlineasy The linkage connections are missing, at least from what I can see. It appears as if someone jury-rigged the linkage with a length of string. The spring is a return spring, which is used for slowing the boat down. You should be able to find a repair manual on line, and it will have a parts list with OMC numbers, which back then were the same for Johnson and Evinrude.

Good Luck,

01-01-2012 11:35 AM
garyguss Something funny in the throttle linkage, weak spring or bent part keeping it from moving all the way when you advance the throttle on the housing, somebody shade tree engineered it with that rope
01-01-2012 11:33 AM
garyguss Try looking it up on here,
They have carb drawings etc.
Evinrude Parts & Johnson Outboard Parts at
12-31-2011 09:39 PM
AdamHowie THe THrottle is on the housing, and when i advance it the engine rev's up but when I pull the string it causes the motor to run even higher than I can attain while only using the throttle on the engine
This thread has more than 10 replies. Click here to review the whole thread.

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

For the best viewing experience please update your browser to Google Chrome