SailNet Community - Reply to Topic
Thread: Raymarine speedo question Reply to Thread
Send Trackbacks to (Separate multiple URLs with spaces) :
Post Icons
You may choose an icon for your message from the following list:

Register Now

In order to be able to post messages on the SailNet Community forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
Please note: After entering 3 characters a list of Usernames already in use will appear and the list will disappear once a valid Username is entered.

User Name:
Please enter a password for your user account. Note that passwords are case-sensitive.


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:


Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.

  Additional Options
Miscellaneous Options

Click here to view the posting rules you are bound to when clicking the
'Submit Reply' button below

  Topic Review (Newest First)
06-29-2014 04:38 PM


Yesterday I installed the new paddlewheel. Went for short motor and the speed gauge now works. It appears to be a little slow compared to the GPS. It was 2 kts slow going with the current and 1 kts slow going against the current so next time I will calibrate it.

FYI, the old impeller looks fine but is noticably harder to spin. I will try sanding the shaft and sides of the old impeller to see if that helps but the new one solved the problem.

06-27-2014 05:31 PM
Raymarine speedo question

I have a plug that fits the thruhull when the paddle wheel assembly is out. If you have an arrangement like this you can work on the wheel in the boat and watch the display as you go. If it works in the boat, it'll work when installed.
06-26-2014 04:53 PM

Hi Guys,

Thanks for the comments. I have done some research and some work:

-I have learned that the transducer is made by airmar (it looks like like ST300).
-Airmar states that the paddlewheel is water lubricated and wears out after 5 years
-The paddlewheel can be removed by pressing out the shaft with a new shaft or a 4D nail.
-They recommend that the paddlewheel be painted with antifouling paint.
-If I spin the wheel the speed registers on the display

So far I have:
-Removed the old paddlewheel. I cleaned the old shaft with sandpaper
-The wheel turns much more easily than before
-The speed display still shows 0, even when I am moving at 6 kts (via GPS)

I have ordered a new paddlewheel kit, which should arrive today.
Tomorrow I will install it. If the speed still reads 0, I will dive the boat and see if something is blocking the flow of water past the paddlewheel.

06-25-2014 10:35 AM
Re: Raymarine speedo question

I don't see how copper paint could possibly make an appreciable difference for the magnetic signal to the Hall effect sensor. I would paint away, but make sure that you are not putting it on too thick. Rubbing on the sides is not the only issue. I would think if the paint smooths out the shape of the paddlewheel, it might have less drag in the water and need calibration.
06-25-2014 08:27 AM
Re: Raymarine speedo question

I'm with jgeissinger on this one. Copper based bottom paint can interfere with the hall effect sensor picking up the signal from the magnets in the spinning paddlewheel. I painted mine once (Standard Horizon instruments) and the speed wouldn't work. Cleaned the paint off and it was fine. A light coating of non-copper antifouling is probably OK.
06-24-2014 11:58 PM
Re: Raymarine speedo question

Originally Posted by jgeissinger View Post
If you used bottom paint on the paddle wheel, you painted it with paint containing metal. The transducer won't read the signal from the paddle wheel. Assuming you can pull it from inside of the boat, clean it of all paint and spin it by hand while someone watches the gauge.
I paint my RM paddle wheel (which is made by Airmar) with copper bottom paint using a q-tip and make sure the paddle wheel has clearance on the sides so it spins freely. I've been doing this for 23 years on various boats and never had a problem unless there is fouling from growth or a transient bit of seaweed while underway.

The RM/Airmar paddle wheel is a cast with a magnetic material--rather like some kitchen magnets use. There is no way metallic bottom paint will interfere with the sensor. At least in salt water, the bottom paint is absolutely necessary if you want the speedo to work all season.
06-24-2014 08:21 PM
Re: Raymarine speedo question

If you used bottom paint on the paddle wheel, you painted it with paint containing metal. The transducer won't read the signal from the paddle wheel. Assuming you can pull it from inside of the boat, clean it of all paint and spin it by hand while someone watches the gauge.
06-24-2014 03:44 PM
Re: Raymarine speedo question

After decades of messing with paddle wheels and cleaning up salt water in the interior as well as having my heart go pitter patter pulling and installing the plug I finally went with an Airmar ultrasonic speedo. They are the supplier for raymarine and you can buy it direct. It is a direct fit for the usual paddlewheel speedo ( but check your dimensions). Stick it in and done. Paint it with transducer paint but not to heavy. Other wise zero maintenance or headache. Wish I did this years ago.
06-24-2014 03:32 PM
capttb The pin is removable on the RM also, one end is smaller, try to push from that end with ice pick or small drill bit. Usually you can clean it without removing the paddle wheel; I use a small blade on my boy scout knife. The wheel must spin freely, I clean and add a drop of oil, temporary but spins better for a day.
06-24-2014 11:46 AM
Raymarine speedo question


My new-to-me boat came with Raymarine instruments. The speedo seemed a little slow on the delivery trip, but it worked. The boat was hauled last October and was on the hard all winter and spring. Two weeks ago I painted the bottom and I noticed the speedo paddle wheel / impeller seemed difficult to turn. I painted the impeller, and splashed the boat. Now the speedo reads 0 no matter how fast the boat goes. I pulled the transducer and there is no marine growth on the paddle but it is hard to turn.

My old boat had ancient Datamarine instruments. When the speed stopped I would pull the transducer, press the pin out of the paddlewheel, clean, install, and be on my way.

The Raymarine transducer seems similar but the pin in the impeller doesn't want to come out and I don't want to break anything.

Am I missing something or do I need need to press the pin out, clean up the inside and press the pin on? I have the manual for the ST60 Tridata instrument, but does not cover the transducer and I'm not sure what transducer it is. There are two transducers, one for depth and one for speed. I believe the instruments are original (2002).

Thanks for any comments.


Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On

For the best viewing experience please update your browser to Google Chrome