SailNet Community - Reply to Topic
Thread: tiny leak in black iron fuel tank Reply to Thread
Send Trackbacks to (Separate multiple URLs with spaces) :
Post Icons
You may choose an icon for your message from the following list:

Register Now

In order to be able to post messages on the SailNet Community forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
Please note: After entering 3 characters a list of Usernames already in use will appear and the list will disappear once a valid Username is entered.

User Name:
Please enter a password for your user account. Note that passwords are case-sensitive.


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:


Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.

  Additional Options
Miscellaneous Options

Click here to view the posting rules you are bound to when clicking the
'Submit Reply' button below

  Topic Review (Newest First)
11-17-2002 12:05 PM
tiny leak in black iron fuel tank

I suspect the leak is at the bottom, usualy at stresed area[weld]. Diesel oil has some Sulphur; when the tank has moisture or water,Sulphuric acid is formed. Well the rest is history.
11-15-2002 04:28 PM
tiny leak in black iron fuel tank

I recently had the same experience. The leak usually signifies rust perforation, usually in the lowest portions of the tank. That is where moisture in the fuel will settle. Sometimes the rust may come from the outside, but not the norm.

There are linings/coatings that can be installed, and possibly a welded patch. But the costs of these two fixes approached or exceeded the cost of a new tank. I ended up replacing with black plastic tank for around $175.
11-15-2002 12:32 PM
tiny leak in black iron fuel tank

We have a very small leak from our
black iron diesel fuel tank. Not
sure where it is. What is the best way
to fix this? Thanks

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On

For the best viewing experience please update your browser to Google Chrome