SailNet Community - Reply to Topic
Thread: Help With Marine Plumbing / Fresh Water Issues Reply to Thread
Send Trackbacks to (Separate multiple URLs with spaces) :
Post Icons
You may choose an icon for your message from the following list:

Register Now

In order to be able to post messages on the SailNet Community forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
Please note: After entering 3 characters a list of Usernames already in use will appear and the list will disappear once a valid Username is entered.

User Name:
Please enter a password for your user account. Note that passwords are case-sensitive.


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:


Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.

  Additional Options
Miscellaneous Options

Click here to view the posting rules you are bound to when clicking the
'Submit Reply' button below

  Topic Review (Newest First)
02-12-2008 03:01 AM
sailaway21 If you have a magnesium rod in your heater it could cause an odor whenin the presence of high iron levels in your water.
02-10-2008 01:30 PM
Loewe Make very certain the odor you have is not glycol. With engine heat exchanger systems it is imperative that you use low/no tox coolant as even a minute amount of automotive antifreeze can kill you. The less lethal possibility is a large build up of minerals in your water heater. Shock treatment as cam described works great for that algae smell / taste. I use chlorine year round at ppm levels compatible with our longevity. I also have stainless tanks that have been unaffected by this treatment for a little over 35 years. Have fun!
02-10-2008 09:54 AM
camaraderie You need to shock treat your lines and tanks. Follow these instructions:
02-10-2008 09:41 AM
Help With Marine Plumbing / Fresh Water Issues

The end of last year I noticed a rather "odd" smell eminating from my fresh water. The smell is stronger with the hot water, although there are traces of it in the cold. I tried those water purification tablets, that lessened the smell somewhat, but not really. I have of course drained the tanks and filled them from another source. Before I undertake something drastic, I thought someone might have some ideas. I have two flexible twenty gallon tanks that I don't believe are the problem and the lines seems relatively okay. The water heater that runs off the heat exchanger on my diesel is rather old. Would this fail (internally) somehow and cause the leaks on it. The smell isn't is bad as rotten eggs or sulfur, but can be potent at times. At the least, it is rather noticeable and when you shower with it, the smell does cling to you. Any suggestions before I tear it all out and replace it all??!!

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On

For the best viewing experience please update your browser to Google Chrome