SailNet Community - Reply to Topic
Thread: Blown out RHI glue Reply to Thread
Send Trackbacks to (Separate multiple URLs with spaces) :
Post Icons
You may choose an icon for your message from the following list:

Register Now

In order to be able to post messages on the SailNet Community forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
Please note: After entering 3 characters a list of Usernames already in use will appear and the list will disappear once a valid Username is entered.

User Name:
Please enter a password for your user account. Note that passwords are case-sensitive.


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:


Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.

  Additional Options
Miscellaneous Options

Click here to view the posting rules you are bound to when clicking the
'Submit Reply' button below

  Topic Review (Newest First)
01-12-2009 06:20 AM
sailingdog If they can't give you a good solution, there's always 5200.
01-10-2009 11:49 PM
SVSnap Ya, that's true, I should def give them a call. I talked to a dealer (not sure if he was officially affiliated with them, just that he sold their stuff) back when I lived in San Fran. He told me PVC construction and sold me this Colle Klebstoff glue...

I'll call them up on Monday and see what they officially suggest.

Thanks man.
01-10-2009 09:15 PM
chucklesR Your first source of info should be the Aquapro website dealing with repairs, but since they have no technical information at all I'd use deal with their people.
You need to know exactly what it's made of and how it was glued and follow the specific recommendations for fixing it. They specify that they sell tubes made of hydropolymer and hypalon.
I couldn't find anything on what they call hypopolymer assuming yours are not Hypalon.
01-10-2009 08:43 PM
Blown out RHI glue

I know it's not a sailboat... but some of you sailors must have had rhib problems at some point right?

Boat: 12' center console Aquapro RHIB
Motor: 25hp honda 4 stroke
Year: 2001
Construction: PVC tubes, Aluminum Hull
Problem: Glue failure at transom-tube joints



I bought it used for cheap a couple years ago and have had lots of fun with it, should I:

a. Try to clean that glue off (googone??) and reglue with "Colle Klebstoff Glue - Groupe ZODIAC 2"?

b. Try to get it professionally redone (I'm cheap tho...)?

c. Pull the Honda off the back and try to put it on a little whaler or similar (tough retrofit...lots of $$$)?

all input appreciated. I'm going back to scrubbing the deck on the real boat....

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On

For the best viewing experience please update your browser to Google Chrome