SailNet Community - Reply to Topic
Thread: Universal 5411 Reply to Thread
Send Trackbacks to (Separate multiple URLs with spaces) :
Post Icons
You may choose an icon for your message from the following list:

Register Now

In order to be able to post messages on the SailNet Community forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
Please note: After entering 3 characters a list of Usernames already in use will appear and the list will disappear once a valid Username is entered.

User Name:
Please enter a password for your user account. Note that passwords are case-sensitive.


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:


Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.

  Additional Options
Miscellaneous Options

Click here to view the posting rules you are bound to when clicking the
'Submit Reply' button below

  Topic Review (Newest First)
05-12-2009 11:56 PM
arf145 Or prop could be badly fouled.
05-12-2009 07:00 PM
JimsCAL If the engine runs, bleeding the fuel system is not necessary. Since the issue seems to be you are down on power, my list of possible problems would include: plugged fuel filter(s), bad fuel, and bad injectors (rebuild or replace).
05-12-2009 02:58 PM
Universal 5411

After 2 years of trouble free use, my 1981 27' Catalina with the Universal 5411 diesel is having a problem. The engine starts well and will rev up. When I throtle back and put the prop in gear the engine will not reach full power. It seems to run at about 1/3 to 1/2 power made only 4 MPH from ramp to marina and took 5 minutes to get to that speed. What do I need to do?

I bleed the fuel system. At the injector one line (closest to front) was delivering a pulse of fuel. Rear line was delivering a steady stream. All else seems to be OK. Some fuel could be 2 years (or more old) Stabilizer was added 07 and 08 winter.


Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On

For the best viewing experience please update your browser to Google Chrome