SailNet Community - Reply to Topic
Thread: Advice for repair of tiller pilot->tiller connection Reply to Thread
Send Trackbacks to (Separate multiple URLs with spaces) :
Post Icons
You may choose an icon for your message from the following list:

Register Now

In order to be able to post messages on the SailNet Community forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
Please note: After entering 3 characters a list of Usernames already in use will appear and the list will disappear once a valid Username is entered.

User Name:
Please enter a password for your user account. Note that passwords are case-sensitive.


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:


Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.

  Additional Options
Miscellaneous Options

Click here to view the posting rules you are bound to when clicking the
'Submit Reply' button below

  Topic Review (Newest First)
09-11-2009 05:53 PM
jgsteven Just to follow up, the fill & re-drill with thickened epoxy her held great for the last three months, and I think I am good to go (since the original job failed after only about 3 hours under autopilot). Thanks!
06-04-2009 11:02 PM
fendertweed I doubt you're weakening it.

I have a Raymarine ST1000 on my P26 and it's been there 6 yrs. (covered w/ tiller cover when not in use. We fashioned a custom made "hump" out of teak to raise the pin to the tillerpilot's height, and drilled a tight hole into which I epoxied the pin.

In 6 yrs. the hump-to-tiller joint (bronze screws plus thickened epoxy joint) is tight and so is the pin.

I could be wrong but think if you fill (use thickened epoxy) & redrill you'll be oK. Mine is coated with Cetol light & clear finish. After 5+ yrs. it is still solid & sound & looks OK.
06-04-2009 08:11 PM
Advice for repair of tiller pilot->tiller connection

The 'pin' in my tiller where the arm of the Raymarine SmartPilot X-5 connects to the tiller has come loose. It appears the force of the tiller drive on the pin acted like a lever and the force on the pin was more than the Epoxy cold hold. An Epoxy field repair lasted a couple hours, but then failed again because the 'hole' in which the pin fits has become enlarged.

My plan is:

1. Drill out the 1/4" hole to 3/4" or so
2. Wet with unthickened epoxy, then fill with thickened, cure
3. drill back to manufacturer defined size and depth (1/4" hold 1/2" deep)
4. Re-epoxy pin into tiller.

My *worry* is:

Am I weakening my tiller with such a large hole drilled and filled with Epoxy? If that 'plug' should ever pop out its a pretty big hole in the tiller... and I have this bad image of myself in rough seas trying to control the boat with only 16" of tiller left.

...and an additional question:

Whats the best way to protect the epoxy from UV? Do I have to paint it or will it take varnish (like the rest of the tiller)?

Thanks for any help/advice,


Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On

For the best viewing experience please update your browser to Google Chrome