SailNet Community - Reply to Topic
Thread: Santana bilge stress cracks Reply to Thread
Send Trackbacks to (Separate multiple URLs with spaces) :
Post Icons
You may choose an icon for your message from the following list:

Register Now

In order to be able to post messages on the SailNet Community forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
Please note: After entering 3 characters a list of Usernames already in use will appear and the list will disappear once a valid Username is entered.

User Name:
Please enter a password for your user account. Note that passwords are case-sensitive.


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:


Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.

  Additional Options
Miscellaneous Options

Click here to view the posting rules you are bound to when clicking the
'Submit Reply' button below

  Topic Review (Newest First)
09-07-2009 11:49 AM
Bilge with cracks on Santana 525 - what did you find out?

I know this post is older, but I would love to know what you found out. We made a full price offer on a Santana 525 (1979) with contract language that says we can check out the mast, bilge and keel. The owner will not go forward with the contract. We still like the boat. So, if you found a way to fix this, maybe we could also.
10-15-2002 08:35 AM
Santana bilge stress cracks

I have a 1979 Santana 525 and the bilge has what I might be stress cracks (the cracks are not open) all the way around it. There is also one crack in the middle of the bilge that is an open crack where water is seeping in at a slow rate. Is it possible that there is a pocket that is holding water that has built up from rain and condensation, or is it definately a crack in the keel? The keel is directly under the bilge and is bolted in. The bolts are dry. Anybody else that has had this problem?

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On

For the best viewing experience please update your browser to Google Chrome