SailNet Community - Reply to Topic
Thread: Catalina 34 Starting Battery Problem Reply to Thread
Title:
Message:
Trackback:
Send Trackbacks to (Separate multiple URLs with spaces) :
Post Icons
You may choose an icon for your message from the following list:
 

Register Now



In order to be able to post messages on the SailNet Community forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
Please note: After entering 3 characters a list of Usernames already in use will appear and the list will disappear once a valid Username is entered.


User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in









Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



  Additional Options
Miscellaneous Options

Click here to view the posting rules you are bound to when clicking the
'Submit Reply' button below


  Topic Review (Newest First)
06-04-2015 03:40 PM
MarkSF
Re: Catalina 34 Starting Battery Problem

"BTW, the inner of the two bolts required a swivel socket and copious swear words."

I remember that bolt. I used 5 ft of extensions, with one universal joint, and my De Walt electric impact driver.
06-04-2015 03:37 PM
MarkSF
Re: Catalina 34 Starting Battery Problem

I've pretty much changed all the cable between batteries, 1-2-both switch, and the starter, after having had similar issues. I found some large voltage drops due to poorly done crimped connections. The actual wire size was OK, but wire was not tinned, crimps were rubbish, and so on.

What I did was make some 6 ft leads for the multimeter, and measure all the voltage drops between battery, and starter, while cranking, systematically. Was losing 2V at one bad crimp. 2 more, here and there. Now 0.7V in the whole circuit.

Don't mess about, go here and order all new battery cables : genuinedealz.com

They use the proper 4 point hydraulic crimper.
06-03-2015 03:18 PM
Scotty C-M
Re: Catalina 34 Starting Battery Problem

Congratulations on your new boat. I also owned a Catalina 34 at one time. Great boats! The above advice/comments are all spot on. With any new boat there is a lot to learn. You, however, have a great resource at your fingertips. Go to the Catalina 34 International Association. You don't have to join to use the website, but join them - it's worth it. Look at the "Critical Upgrades" section. Take a bit of time to go over the information there - there's a lot of it. Look at the engine 101 topics. You will find a wealth of information there specific to the starting issues that you are asking about. Have fun with your new boat!!
06-03-2015 12:22 PM
brent
Re: Catalina 34 Starting Battery Problem

I too purchased the Catalina 34 last summer. Someone pointed out that I was holding in the glow plug button while trying to hit the starter button. When I released the glow plug button and then hit the start button, no problems, fired right up!
03-06-2010 11:33 PM
Maine Sail There is something wrong and it's very unlikely that it's your batts. That starter is a .8 Kw and should easily be started by even a personal water craft battery.

Check:

1) Starter ground to engine (it is case grounded make sure it is clean)
2) All connections
3) Circuit path to starter
4) Starter
5) Battery switch
6) Glow plug circuit and glow plugs. (it is not clear whether it is not cranking or starting)

Also post this over on the C-34 forums (LINK)
03-06-2010 07:56 PM
olson34
"regarding fixin' what aint broke"

Strictly in the "FWIW" dept, at about a thousand hours I pulled the starter off of our 23 hp diesel (Universal M25XP) and took it in for a preventative maint. rebuild.
BTW, the inner of the two bolts required a swivel socket and copious swear words.

It had been working OK, starting the engine on either battery.
A mechanic friend advised me to go ahead and do this, as a p.m. idea.

About $135 later it was back, rebuilt, with a new solenoid (they are evidently not a rebuildable item).
The shop is a highly-regarded local marine starter/alternator shop and the proprietor is always willing to explain stuff. He liked the idea of "fixing" this before it might let me down in the midst of summer vacation cruising.
The punch line: it cranked the engine a LOT faster when reinstalled!

So, what slight little lesson there is to be learnt here is that sometimes these parts wear very slowly and performance degrades... slowly...

It's kinda like pulling the injectors and testing the spray pattern every so many hours, it pays to have an engine maint. sched.

As Forest said, "That's all I know about That."


L
03-06-2010 07:48 PM
mitiempo Also check that your glow plug wiring is good if you have them. A lot of Catalinas were wired with the glow plugs getting their power through the panel with small wires. The best solution is to use a solenoid off the engine panel and wire the glow plugs direct from the start battery if this is the case.
03-06-2010 06:46 PM
gulftex
c34 starting problem

I have a 1986 c34.Ihad the same problem,I had to use both battries to start.I relaced all battry cables with larger ones (welding leads) Battries were so far from engine small cables could not handle the draw.Installed two Wal-Mart marine battries,engine now starts on one battery.If your starter battery is close to engine,Iwould check connections and starter.
Gulftex
c34 hull#13
06-04-2002 03:42 AM
Jeff_H
Catalina 34 Starting Battery Problem

You may also have a starter on the way out.
06-04-2002 03:25 AM
lgsailor52
Catalina 34 Starting Battery Problem

Look for corrosion at the terminal connections and your ground. Also look at your power (battery) switch. There may be internal corrosion, or corrosion at the connections. A loose connection may also be the cause.
This thread has more than 10 replies. Click here to review the whole thread.

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On

 
For the best viewing experience please update your browser to Google Chrome