SailNet Community - Reply to Topic

   Search Sailnet:

 forums  store  


Quick Menu
Forums           
Articles          
Galleries        
Boat Reviews  
Classifieds     
Search SailNet 
Boat Search (new)

Shop the
SailNet Store
Anchor Locker
Boatbuilding & Repair
Charts
Clothing
Electrical
Electronics
Engine
Hatches and Portlights
Interior And Galley
Maintenance
Marine Electronics
Navigation
Other Items
Plumbing and Pumps
Rigging
Safety
Sailing Hardware
Trailer & Watersports
Clearance Items

Advertise Here






Go Back   SailNet Community > Boat Builders Row > Bristol > Bristol 27 - Anode Placement
 Not a Member? 


Thread: Bristol 27 - Anode Placement Reply to Thread
Title:
  

By choosing to post the reply below you agree to the rules you agreed to when joining Sailnet.
Click Here to view those rules.

Message:
Trackback:
Send Trackbacks to (Separate multiple URLs with spaces) :
Post Icons
You may choose an icon for your message from the following list:
 

Register Now

In order to be able to post messages on the SailNet Community forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
Please note: After entering 3 characters a list of Usernames already in use will appear and the list will disappear once a valid Username is entered.
User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Click here to view the posting rules you are bound to when clicking the
'Submit Reply' button below


Additional Options
Miscellaneous Options

Click here to view the posting rules you are bound to when clicking the
'Submit Reply' button below


Topic Review (Newest First)
04-22-2010 01:06 PM
johnshasteen If you have a Yanmar diesel, there is also a zinc screwed into the engine block in the rear of the engine. It looks like a square head bolt, remove it and a finger-size zinc screws onto it.
04-20-2010 11:15 AM
FishmanTx We have a 34 and the only zinc we have is on the shaft.
04-13-2010 05:51 PM
sailstein Hi, I have a 1968 bristol 27, different design then the 75 I think. My boat has an anode attached to the hull near where the keel flares out, midship. Don't know if this is factory installed or an aftermarket thing.
03-29-2010 11:35 AM
Fstbttms
Quote:
Originally Posted by anoser View Post
Thanks for the reply...didn't look like there was much room on either but I'll take a closer look...

I figured as much. Thanks Again!
If you have limited room on the shaft for a standard streamlined collar zinc, you may be able to use a limited-clearance collar, like this:



If that won't fit, consider a prop nut zinc like this:

03-29-2010 11:21 AM
anoser Thanks for the reply...didn't look like there was much room on either but I'll take a closer look...

I figured as much. Thanks Again!
03-29-2010 11:17 AM
Fstbttms
Quote:
Originally Posted by anoser View Post
I called the old owner and he said he never had them and never had problems because of the copper in the bottom kote.
You should have an anode on the shaft or prop. Probably don't need one anywhere else. I can say the previous owner was deluded if he thought his anti fouling paint was providing protection from corrosion.
03-29-2010 08:48 AM
anoser
Bristol 27 - Anode Placement

Hi All,

I'm the proud new owner of a 1975 Bristol 27. I finally got the hull ready and one last minute thing I noticed is that there are no visible anodes anywhere. On my 24 they were on the rudder.

I'm in the upper part of the Chesapeake, so maybe they didn't worry about it, but it just seems odd to me.

Anyone know about the anode placement on the 27? Where it normally is...any pics would be great. Maybe I'll skip it this season because I called the old owner and he said he never had them and never had problems because of the copper in the bottom kote.

Anyway...any advice or feedback would be appreciated.

-Alex

 
Posting Rules
You may post new threads
You may post replies
You may post attachments
You may edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On


All times are GMT -4. The time now is 07:59 PM.

Add to My Yahoo!         
Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
SEO by vBSEO 3.6.1
(c) Marine.com LLC 2000-2012

The SailNet.com store is owned and operated by a company independent of the SailNet.com forum. You are now leaving the SailNet forum. Click OK to continue or Cancel to return to the SailNet forum.