SailNet Community - Reply to Topic

   Search Sailnet:

 forums  store  


Quick Menu
Forums           
Articles          
Galleries        
Boat Reviews  
Classifieds     
Search SailNet 
Boat Search (new)

Shop the
SailNet Store
Anchor Locker
Boatbuilding & Repair
Charts
Clothing
Electrical
Electronics
Engine
Hatches and Portlights
Interior And Galley
Maintenance
Marine Electronics
Navigation
Other Items
Plumbing and Pumps
Rigging
Safety
Sailing Hardware
Trailer & Watersports
Clearance Items

Advertise Here






Go Back   SailNet Community > On Board > Gear & Maintenance > Engines > Diesel > Running MD7A for sale
 Not a Member? 

Diesel This is a forum dedicated to diesel engines and their applicable accessories.


Thread: Running MD7A for sale Reply to Thread
Title:
  

By choosing to post the reply below you agree to the rules you agreed to when joining Sailnet.
Click Here to view those rules.

Message:
Trackback:
Send Trackbacks to (Separate multiple URLs with spaces) :
Post Icons
You may choose an icon for your message from the following list:
 

Register Now

In order to be able to post messages on the SailNet Community forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
Please note: After entering 3 characters a list of Usernames already in use will appear and the list will disappear once a valid Username is entered.
User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Click here to view the posting rules you are bound to when clicking the
'Submit Reply' button below


Additional Options
Miscellaneous Options

Click here to view the posting rules you are bound to when clicking the
'Submit Reply' button below


Topic Review (Newest First)
07-25-2011 02:57 PM
shogan50 All parts sold. Sorry. Interestingly, the engine and transmission went separately, to Canada and the Netherlands respectively.
07-25-2011 02:39 AM
kc7ckc
md7a

Hi all
Looking for a parts motor so if they are still around drop me a note

Joel
S/V Gypsy Wind Tacoma
04-27-2011 08:26 PM
simpsoned Mine looks similar, but it is probably a few years older...my Newport is a 78...your new one got wet...I found out my boat was the only one on Lake Pend O'rielle that has been hit by lighting...the previous owner had the entire boat re-wired (or at least re-spliced)...Ed
04-26-2011 12:26 AM
shogan50 I found a used Beta 14 that sank during the repower - not that the previous owner disclosed the sinking part. Had that not come along, I would have rebuilt the MD7a and put a heat exchanger in it, but I might be uniquely qualified to do that being a mechanical engineer and former auto mechanic. You can follow the saga on the first link in my signature if you are interested. Here is a video of the MD7a just before I removed it. I'd be interested to know how yours compares. YouTube - MD7A running in boat
04-25-2011 07:14 PM
simpsoned Hey Shogun...what did you replace it with. I am probably going to be in the same boat (pardon the pun) as I have an old MD7A in my Newport...same symptoms as yours...
Thanks
Ed
04-25-2011 03:11 AM
Dutch61
Gearbox MD7A

Hi Shogun,

The transmisson of my MD7A has frostdamage. It seems that yours is slightly better If we can agree on a price, would you send it to The Netherlands?

Dutch61 (Ruud)
03-27-2011 10:02 PM
shogan50
Running MD7A for sale

Hopefully this isn't against forum policy. I just pulled an MD7A from my Islander. It runs, alternator, starter, etc all work, but the engine is tired. It runs cold - takes about 15 minutes to get to temperature if running it hard, even with new thermostat. Alternator has a 1984 date on it. Shoot me a private message if you are interested in parts or whole thing. Transmission works, but doesn't find neutral very easily when running. I've read on a forum on this site that it isn't a difficult fix. It is currently located in the Everett marina, Washington State. I can crate for shipping. I have video of it running in boat about a week ago.

 
Posting Rules
You may post new threads
You may post replies
You may post attachments
You may edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On


All times are GMT -4. The time now is 11:24 PM.

Add to My Yahoo!         
Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
SEO by vBSEO 3.6.1
(c) Marine.com LLC 2000-2012

The SailNet.com store is owned and operated by a company independent of the SailNet.com forum. You are now leaving the SailNet forum. Click OK to continue or Cancel to return to the SailNet forum.