SailNet Community - Reply to Topic

   Search Sailnet:

 forums  store  


Quick Menu
Forums           
Articles          
Galleries        
Boat Reviews  
Classifieds     
Search SailNet 
Boat Search (new)

Shop the
SailNet Store
Anchor Locker
Boatbuilding & Repair
Charts
Clothing
Electrical
Electronics
Engine
Hatches and Portlights
Interior And Galley
Maintenance
Marine Electronics
Navigation
Other Items
Plumbing and Pumps
Rigging
Safety
Sailing Hardware
Trailer & Watersports
Clearance Items

Advertise Here






Go Back   SailNet Community > On Board > Gear & Maintenance > Engines > Diesel > Yanmar instrument panel source -used?
 Not a Member? 

Diesel This is a forum dedicated to diesel engines and their applicable accessories.


Thread: Yanmar instrument panel source -used? Reply to Thread
Title:
  

By choosing to post the reply below you agree to the rules you agreed to when joining Sailnet.
Click Here to view those rules.

Message:
Trackback:
Send Trackbacks to (Separate multiple URLs with spaces) :
Post Icons
You may choose an icon for your message from the following list:
 

Register Now

In order to be able to post messages on the SailNet Community forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
Please note: After entering 3 characters a list of Usernames already in use will appear and the list will disappear once a valid Username is entered.
User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Click here to view the posting rules you are bound to when clicking the
'Submit Reply' button below


Additional Options
Miscellaneous Options

Click here to view the posting rules you are bound to when clicking the
'Submit Reply' button below


Topic Review (Newest First)
05-10-2011 01:30 PM
casey1999 Sounds good.

My panel is mounted in the cabin so not so much corrosion problem. My wiring harness (and connections) are not in good shape either, but I know what to wiggle to get it to work (repair is on the list). It would be good to use some anti-corrosion spray on everything (make sure it will not damage rubber) including in the wiring harness plugs and splice plugs.
05-10-2011 12:50 PM
mbsl98 Thanks for the tips, Casey. I finally got all of the pieces separated from the old panel, and yesterday found I could order the black plastic panel itself, plus the wiring harness with plugs to fit the various units in the panel, plus a new tach, from Torrensen. They were extremely helpful in sorting out what was available (harness is coming from Georgia, via Michigan). The plastic piece was broken by the rust expanding around the body of the tach - that caused the thin corner that surrounds the tach to break into a separate piece that I could have glued back, but for $28 got a new one. The tach itself has actual rust holes through the body - suprising that it still seems to work fine, but certainly not a sealed unit any more. The tach body, and the hold downs for the tach and for the buzzer, are made of very rust prone cheap metals, while the rest of the parts seem to have weathered the water pretty well (ignition switch, buzzer, switches and lights). Some of the pins inside the wiring harness plugs are also well corroded, one broken off as I separated the halves of the plugs, but again, everythhing was still working until I opened it up, although clearly marginal as far as reliability in tough going.

For others with engine panels mounted in the cockpit, I would suggest a quick check of the seal where the panel mets the fiberglass. Mine was mounted to a teak panel that was then mounted to the fiberglass, and it leaked where the teak met the fiberglass.

In the end, this was a good chance to really clean up the main electrics in a 25 year old boat, without the need to suffer a breakdown at a bad time before discovering the need to do it.
05-09-2011 09:06 PM
casey1999 Mack Boring & Parts Company - The Power Behind The Power

Above carries OEM and a after market. They are pretty expensive. I have seen some on e-bay but still high dollar even for used. I would take your old panel and rebuild with water proof led lights (blue sea from west marine). The panel is basically some indicator lights, a buzzer, and some swtiches. Try to use your old rpm gage. could probably buy all the parts for less than $100. used I seen for $400. You could call Mack boring- maybe they have an old one they would sell you.
05-07-2011 08:15 AM
mbsl98
Yanmar instrument panel source -used?

Does anyone have a suggestion where I might hunt for a good used instrument panel for my 3GM Yanmar? Mine has apparently been getting wet from the back and its turning into a block of rust -casings and retainers of instruments, connectors, etc. It all looks fine from the front, and works, but clearly not very confidence inspiring. Mine is the most common Yanmar panel, and was used with various motors. Torreson link to part #128170-91002:
Yanmar 128170-91002 - Torresen Marine - The Sailboat Specialist

Thanks, Mike

 
Posting Rules
You may post new threads
You may post replies
You may post attachments
You may edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On


All times are GMT -4. The time now is 03:17 PM.

Add to My Yahoo!         
Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
SEO by vBSEO 3.6.1
(c) Marine.com LLC 2000-2012

The SailNet.com store is owned and operated by a company independent of the SailNet.com forum. You are now leaving the SailNet forum. Click OK to continue or Cancel to return to the SailNet forum.