SailNet Community - Reply to Topic

   Search Sailnet:

 forums  store  


Quick Menu
Forums           
Articles          
Galleries        
Boat Reviews  
Classifieds     
Search SailNet 
Boat Search (new)

Shop the
SailNet Store
Anchor Locker
Boatbuilding & Repair
Charts
Clothing
Electrical
Electronics
Engine
Hatches and Portlights
Interior And Galley
Maintenance
Marine Electronics
Navigation
Other Items
Plumbing and Pumps
Rigging
Safety
Sailing Hardware
Trailer & Watersports
Clearance Items

Advertise Here






Go Back   SailNet Community > On Board > Gear & Maintenance > bilge pump blowing fuses
 Not a Member? 


Thread: bilge pump blowing fuses Reply to Thread
Title:
  

By choosing to post the reply below you agree to the rules you agreed to when joining Sailnet.
Click Here to view those rules.

Message:
Trackback:
Send Trackbacks to (Separate multiple URLs with spaces) :
Post Icons
You may choose an icon for your message from the following list:
 

Register Now

In order to be able to post messages on the SailNet Community forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
Please note: After entering 3 characters a list of Usernames already in use will appear and the list will disappear once a valid Username is entered.
User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Click here to view the posting rules you are bound to when clicking the
'Submit Reply' button below


Additional Options
Miscellaneous Options

Click here to view the posting rules you are bound to when clicking the
'Submit Reply' button below


Topic Review (Newest First)
05-16-2011 05:06 PM
CapitainMike Put a stainless strainer round it and clean it regularly. its some thing that should be carried out on a regular basis'
05-16-2011 11:23 AM
smeyers18
Gunk in the bilge

I had the same issue with my bilge pump just now and it turned out, as far as I know, to be a little hard chunk left over from last years projects that was sitting directly under the impeller in the base of the bilge pump. I'm assuming it fell out when I removed the top of the pump to see what was going on. Lesson I learned is to look for the physical culprit first before going after a potential electrical issue.

Scott
Currently cruising down the Leeward Islands. Check us out at... Windtraveler or on Facebook at... Windtraveler | Facebook
05-15-2011 04:42 AM
CapitainMike
Quote:
Originally Posted by GaryHLucas View Post
I am a bilge pump freak too. I don't even have one, manual or electric, but then neither do any of the other Etap owners! I do of course have a sponge and a bucket, as we all do.

Gary H. Lucas
You ETAP owners keep on about unsinkable that's really great but I think you have missed the point here. If you get holed below the water line you have to keep your batteries dry for obvious reasons and if there is no wind you are relying on your engine

I have 4 working bilge pumps, fore peak 1 manual. 1 saloon auto and manual plus float switch, 2 in the engine bilge auto with sensor its the deepest bilge in the boat and a spare pump and float switch.

If it starts to come in you got to get it out fast and a bucket is not a good idea.

05-14-2011 11:27 PM
mitiempo Not any more!
05-14-2011 10:39 PM
cruisingdream 3 year old thread
05-14-2011 09:09 PM
GaryHLucas
Quote:
Originally Posted by Stillraining View Post
Buy a new one! cheapest insurance you can buy...also replace your fuse it my be worn out and tripping prematurely ..I have had a few go bad they are just like any other mechanical/electrical device in wet environments

Im a bilge pump freak...I have 4 on-board...3 electric and one manual...one of the electric is manually switched and big...the other 2 are auto switched one mounted slightly higher with an audible alarm ...
I am a bilge pump freak too. I don't even have one, manual or electric, but then neither do any of the other Etap owners! I do of course have a sponge and a bucket, as we all do.

Gary H. Lucas
05-13-2011 03:34 PM
CapitainMike
Quote:
Originally Posted by mauidan15 View Post
So as the title says the bilge pump keeps blowing fuses, the wiring is getting wet so should I just try to rewire it, or install a new one?
Please be more precise what wiring is getting wet and where.

What is the make of the pump

What is the size of the fuse you are using

Is there a recommended fuse size for that pump

Are you using a float switch

What are the amps of the pump
04-26-2008 06:59 PM
bubb2 You can tell allot about a man by the way he keeps his bilge. very nice Rain
04-26-2008 05:40 PM
Stillraining Already handled accordingly..

My bilge is different then most with a separate small extra deep depression which will only house one pump and switch..

The third big pump is under the engine
04-26-2008 05:12 PM
ebs001 Unless the pump has a built in float switch the back-up pump does not have to be mounted higher than the primary only the float switch. If you mount the pump higher than the "off" point of its float switch it will not turn off.
This thread has more than 10 replies. Click here to review the whole thread.

 
Posting Rules
You may post new threads
You may post replies
You may post attachments
You may edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On


All times are GMT -4. The time now is 11:19 AM.

Add to My Yahoo!         
Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
SEO by vBSEO 3.6.1
(c) Marine.com LLC 2000-2012

The SailNet.com store is owned and operated by a company independent of the SailNet.com forum. You are now leaving the SailNet forum. Click OK to continue or Cancel to return to the SailNet forum.