SailNet Community - Reply to Topic
Thread: Windlass fuse on Oceanis 393 Reply to Thread
Send Trackbacks to (Separate multiple URLs with spaces) :
Post Icons
You may choose an icon for your message from the following list:

Register Now

In order to be able to post messages on the SailNet Community forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
Please note: After entering 3 characters a list of Usernames already in use will appear and the list will disappear once a valid Username is entered.

User Name:
Please enter a password for your user account. Note that passwords are case-sensitive.


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:


Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.

  Additional Options
Miscellaneous Options

Click here to view the posting rules you are bound to when clicking the
'Submit Reply' button below

  Topic Review (Newest First)
06-07-2011 04:51 AM
TejasSailer Our windlass also has two breakers, one low amp breaker on the DC panel for the controller, and one high amp breaker near the battery switches for the windlass itself.
06-06-2011 04:31 PM
Breaker found, windlass working!

Dear TejasSailer and Vasco, thank you very much for your help. I had already tried to push a red button on the breaker in the aft cabin without effect. After reading your answers, I went back to the aft cabin, brought a flashlight, and found a black toggle I hadn't seen. The windlass works again.
06-04-2011 06:22 PM
TejasSailer The problem might be that a breaker separate from the breakers on the 12-volt panel has tripped. Sorry, I don't know where to tell you to look. On our Beneteau the breaker is on the starboard side below the battery switches, but that's because where we installed it. That the breaker we got via Beneteau has tripped is not all that obvious. I think that I recall a toggle swings down or out that must be latched up or in to reset.
06-04-2011 06:12 PM
Vasco On my 393 there is a breaker by the battery switches in the aft cabin.
06-04-2011 05:14 PM
Windlass fuse on Oceanis 393

The Leroy Somer electric anchor windlass on our Oceanis 393 from 2002 died suddenly when the chain jammed. Or rather, the rope at the end of the 20 m chain jammed. I suspect a fuse blew, but I can't find it. Does anyone know where it is? Should there be a rope there at all? The windlass seem to be made for chains only.

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

For the best viewing experience please update your browser to Google Chrome