SailNet Community - Reply to Topic

   Search Sailnet:

 forums  store  


Quick Menu
Forums           
Articles          
Galleries        
Boat Reviews  
Classifieds     
Search SailNet 
Boat Search (new)

Shop the
SailNet Store
Anchor Locker
Boatbuilding & Repair
Charts
Clothing
Electrical
Electronics
Engine
Hatches and Portlights
Interior And Galley
Maintenance
Marine Electronics
Navigation
Other Items
Plumbing and Pumps
Rigging
Safety
Sailing Hardware
Trailer & Watersports
Clearance Items

Advertise Here






Go Back   SailNet Community > On Board > Gear & Maintenance > Engines > Diesel > Stalling Universal 5424 Engine
 Not a Member? 


Thread: Stalling Universal 5424 Engine Reply to Thread
Title:
  

By choosing to post the reply below you agree to the rules you agreed to when joining Sailnet.
Click Here to view those rules.

Message:
Trackback:
Send Trackbacks to (Separate multiple URLs with spaces) :
Post Icons
You may choose an icon for your message from the following list:
 

Register Now

In order to be able to post messages on the SailNet Community forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
Please note: After entering 3 characters a list of Usernames already in use will appear and the list will disappear once a valid Username is entered.
User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Click here to view the posting rules you are bound to when clicking the
'Submit Reply' button below


Additional Options
Miscellaneous Options

Click here to view the posting rules you are bound to when clicking the
'Submit Reply' button below


Topic Review (Newest First)
08-05-2011 06:54 PM
wescarroll Disconnect your fuel lines at the engine, and use air pressure to blow back(back-flush)through your fuel system until you hear bubbling sounds from the fuel tank. While doing this, examine the ENTIRE fuel system for leaks, any leaks behind the fuel-pump are where you are sucking air into the system, and are your problem. If the system is not compromised, you should have cleared the screens and such with the compressed air. Drain each section of fuel line between the filters and discard that fuel. Reconnect and bleed the system and that should do it.
07-27-2011 01:29 AM
CalebD Changing your fuel filters on your diesel will become a habit so find a good place to buy them!
07-26-2011 10:13 PM
ryderstk Good News.... Changed all the filters and engine is purring once again. Will take her out this weekend and give her a good shake down....
07-25-2011 10:36 PM
CalebD Could some diesel fuel sludge have clogged up on one (or more) of your injectors?
Sounds like the original fuel tank was in bad, bad shape.
By all means check the pumps and any screens first as mentioned by others. If the fuel pump and lines are not the issue then the next step is to check inside the engine.
07-25-2011 09:43 PM
dabnis Ran OK on the outboard tank? If there is a screen on the intake tube it may be partially plugged? If you can get it out it may be worth checking. Or, maybe an air leak between the suction side of the pump and the tank, maybe somewhere in the filter or connections? Fuel line crimped?

Dabnis
07-25-2011 09:20 PM
deniseO30 don't know which one you may have, but some fuel pumps have a little strainer in the line that is not always noticed when they are installed. do you have full flow of fuel with the line disconnected from the engine? (into a bucket)
07-25-2011 09:08 PM
ryderstk
Stalling Universal 5424 Engine

HELP.... I have a Universal 5424 Engine that is giving me fits. I bought the boat in April and have been working to get all the essential systems in working order and so far I have been stumped on getting the engine to run reliably... I started by draining the 20 gal original fuel tank. There was 15 gal of old fuel, of which 10 gal was water. I changed the oil in both the transmission and the engine. Both of which were free of any water. I replaced all the fuel lines, water lines, and all the filters, as well as a new elec fuel pump. I also installed a new heat exchanger and put in 50/50 water anti-freeze. I then hooked up an outboard tank in the galley, above engine to feed first into a Racor fuel water seperator, then to the elec fuel pump, then to the engine mounted filter.

Next I bled all the lines starting at racor moving to the engine mounted filter bleed screw and then to the injector pump bleed screw. Engine sprang to life after only a few attempts. I was at that time on a mooring at Davis Island in Tampa and needed to move to a marina closer to my house to finish the refit. It took me 3 hours to get to the other end of Tampa Bay, but she ran perfectly.

Whats the problem you might ask. Well, once I got the my new marina, I wanted to have the tank professionally cleaned and fuel polished. Which I did, and what a mess was in that tank. After 3 hours of cleaning and polishing, the inside of the tank was like new. I decided to let them remove the fuel that we used to clean the tank and start out fresh. I even replaced the racor and engine fuel filters to ensure that I was starting out with all new parts in the system once again.

I bleed the entire system by the book and once again, the engine purred like a cat. All was right with the world...... THEN the RPM began to fluctuate and finally the engine stalled. I bleed the system again, and could only run for a couple of minutes and then stall again.

Here is what is have check so far and still I have the same problem... Run a couple of minutes with fluctuation RPM then Stall...

1. Bleed Lines
2. Checked vent line clear, by trying to run with fuel cap off
3. Replace the return line and all hoses .... again

I am going to change the filters again tomorrow, but I am running out of ideas.... Soon I am going to have to call in a mechanic, but I wanted to try and solve the problem myself if at all possible.

Thanks,
S/V Island Fever

 
Posting Rules
You may post new threads
You may post replies
You may post attachments
You may edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On


All times are GMT -4. The time now is 09:36 AM.

Add to My Yahoo!         
Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
SEO by vBSEO 3.6.1
(c) Marine.com LLC 2000-2012

The SailNet.com store is owned and operated by a company independent of the SailNet.com forum. You are now leaving the SailNet forum. Click OK to continue or Cancel to return to the SailNet forum.