SailNet Community - Reply to Topic

   Search Sailnet:

 forums  store  


Quick Menu
Forums           
Articles          
Galleries        
Boat Reviews  
Classifieds     
Search SailNet 
Boat Search (new)

Shop the
SailNet Store
Anchor Locker
Boatbuilding & Repair
Charts
Clothing
Electrical
Electronics
Engine
Hatches and Portlights
Interior And Galley
Maintenance
Marine Electronics
Navigation
Other Items
Plumbing and Pumps
Rigging
Safety
Sailing Hardware
Trailer & Watersports
Clearance Items

Advertise Here






Go Back   SailNet Community > On Board > Gear & Maintenance > JRC 1000 Radar won't power on??
 Not a Member? 


Thread: JRC 1000 Radar won't power on?? Reply to Thread
Title:
  

By choosing to post the reply below you agree to the rules you agreed to when joining Sailnet.
Click Here to view those rules.

Message:
Trackback:
Send Trackbacks to (Separate multiple URLs with spaces) :
Post Icons
You may choose an icon for your message from the following list:
 

Register Now

In order to be able to post messages on the SailNet Community forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
Please note: After entering 3 characters a list of Usernames already in use will appear and the list will disappear once a valid Username is entered.
User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Click here to view the posting rules you are bound to when clicking the
'Submit Reply' button below


Additional Options
Miscellaneous Options

Click here to view the posting rules you are bound to when clicking the
'Submit Reply' button below


Topic Review (Newest First)
03-28-2012 07:27 PM
Brent Swain
Re: JRC 1000 Radar won't power on??

My JRC radar did that . I was quoted $650 for repair. Bought a new radar. Definitely not from the people who gave me the quote ( Victoria Marine electric)
03-28-2012 07:21 AM
Somekindofaviking
Re: JRC 1000 Radar won't power on??

Keep in mind..
A voltmeter is not always the best tool, troubleshooting 12v systems..
They are sometimes too sensitive for the task..
I have been fooled more than once, by a digital voltmeter..
It will sometimes read 12-13 volt, but there will not be enough amp's to light a 5W light bulb at the socket...
Most Car electricians, uses the oldschool circuit tester with a built in bulb..
For circuit testing i mean..
It is a little different, when testing circuitboards..

I always have one of these lying around... : PICO WIRING 0690PT - Pico Circuit Testers - Overview - SummitRacing.com

Just my thoughts tho...
03-28-2012 03:53 AM
Rockter
Re: JRC 1000 Radar won't power on??

I have got one.
When first powered up, it takes about 90 seconds before the display will show the sweep.
There is a count-down in the centre of the screen.
I cannot remember if it beeps when I first power up. I suspect it does.

Check the power supply. Make sure you are feeding enough volts. Start your engine to improve the voltage supply, if necessary.
.
03-28-2012 01:55 AM
kc7ckc
Re: JRC 1000 Radar won't power on??

Same here, contacted JRC in Seattle and a new board is $650.00 , so I was told if you really love your jrc 1000?
03-02-2012 10:31 PM
boatseeker North-easter and anyone else with JRC Radar 1000 problems

I am having the same problem on a unit I salvaged from an abandoned boat. I contacted JRC who told me the main board needs replacing. If you repaired it what action was needed?
01-11-2011 02:06 PM
Faster There is a (3 minute?) warmup time.. sometmes for some reason the contrast gets adjusted.. have you tried to "increase" the contrast during the warmup time? You should see the countdown timer for warm up...
01-11-2011 12:37 PM
QuickMick when you checked the 'in line' one you mean the 5a fuse that resides in the power cable?
01-11-2011 02:50 AM
AdmiralDan I'm having the exact same problem with my JRC 1000. Has anyone solved this problem or do these display units just die?
08-17-2007 09:31 PM
Northeaster Cam - Thanks for the contact info. I'll give them a call!
08-17-2007 09:05 PM
camaraderie North...well, other than checking the contacts for the plug on your display unit it looks like what you have is in technical terms "a dead unit". There are no user accesible service items so I'd suggest you send the puppy off to JRC or call their tech line:
SERVICE PHONE: 206-654-5644

SERVICE FAX: 206-654-7030
Service Technicians marineservice@jrcamerica.com


Good luck!
This thread has more than 10 replies. Click here to review the whole thread.

 
Posting Rules
You may post new threads
You may post replies
You may post attachments
You may edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On


All times are GMT -4. The time now is 05:51 PM.

Add to My Yahoo!         
Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
SEO by vBSEO 3.6.1
(c) Marine.com LLC 2000-2012

The SailNet.com store is owned and operated by a company independent of the SailNet.com forum. You are now leaving the SailNet forum. Click OK to continue or Cancel to return to the SailNet forum.