SailNet Community - Reply to Topic
Thread: head water intake smell Reply to Thread
Title:
Message:
Trackback:
Send Trackbacks to (Separate multiple URLs with spaces) :
Post Icons
You may choose an icon for your message from the following list:
 

Register Now



In order to be able to post messages on the SailNet Community forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
Please note: After entering 3 characters a list of Usernames already in use will appear and the list will disappear once a valid Username is entered.


User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in









Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



  Additional Options
Miscellaneous Options

  Topic Review (Newest First)
10-04-2006 10:41 AM
Gene T I rigged mine up to run on fresh water. There are plenty of recommendations not to do this for health reasons, so you have to do it correctly. Wouldn't want to do this for cruising as it would use too much water and one would use the head enough to not have the smell anyway.
Peggy Hall has a book on the subject of head odors.
10-04-2006 08:29 AM
sailingdog I flush the head via fresh water before leaving the boat. A lot of it really depends on where you're sailing, since different waters have different critters in them. Have you tried closing the through-hull while still out on the open ocean, to see if the cleaner water out there helps keep the line from stinking as much...might be worth a shot.

BTW, you can generally prime a head by dumping water directly in to the bowl IIRC, but YMMV depending on which head you have.
10-04-2006 02:56 AM
JHodor
head water intake smell

yes we all know water sitting in the intake line can turn to a pure sulfur smell.


What has anyone done to combat this? I've added the inline blue pills but that doesn't seem to do it. The first flush each time we get back to the boat is awlful. This is a newer boat and I know my system is set up properly. Even it only 6 hours goes by the next flush is bad.

I've replaced the intake line a before to start fresh. This helps only for about 2 months.

Help please? Thoughts on how to fix this? Chlorine tablets in the intake line?


I've started a process of always shutting off the seacock to pump the head real dry. this doesn't seem to help much better and what it did a couple of times is cause an airlock in my system and the head wouldn't prime at all. I had to take off the intake and shoot a hose up there while pumping to get it to "take"



again thoughts???

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On

 
For the best viewing experience please update your browser to Google Chrome