SailNet Community - Reply to Topic

   Search Sailnet:

 forums  store  


Quick Menu
Forums           
Articles          
Galleries        
Boat Reviews  
Classifieds     
Search SailNet 
Boat Search (new)

Shop the
SailNet Store
Anchor Locker
Boatbuilding & Repair
Charts
Clothing
Electrical
Electronics
Engine
Hatches and Portlights
Interior And Galley
Maintenance
Marine Electronics
Navigation
Other Items
Plumbing and Pumps
Rigging
Safety
Sailing Hardware
Trailer & Watersports
Clearance Items

Advertise Here






Go Back   SailNet Community > On Board > Gear & Maintenance > Engines > Diesel > Westerbeke 30B Deceleration Stumble/Stalling
 Not a Member? 

Diesel This is a forum dedicated to diesel engines and their applicable accessories.


Thread: Westerbeke 30B Deceleration Stumble/Stalling Reply to Thread
Title:
  

By choosing to post the reply below you agree to the rules you agreed to when joining Sailnet.
Click Here to view those rules.

Message:
Trackback:
Send Trackbacks to (Separate multiple URLs with spaces) :
Post Icons
You may choose an icon for your message from the following list:
 

Register Now

In order to be able to post messages on the SailNet Community forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
Please note: After entering 3 characters a list of Usernames already in use will appear and the list will disappear once a valid Username is entered.
User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Click here to view the posting rules you are bound to when clicking the
'Submit Reply' button below


Additional Options
Miscellaneous Options

Click here to view the posting rules you are bound to when clicking the
'Submit Reply' button below


Topic Review (Newest First)
08-05-2012 09:50 AM
lenkrauss
Re: Westerbeke 30B Deceleration Stumble/Stalling

. . .a test was done with fresh fuel in jug piped directly to IP (using a external small lift pump and inline filter) and a new return line back to the jug -- thus, my boat's fuel system was totally eliminated. . .

Quote:
Originally Posted by Stu Jackson View Post
Have your removed the filter screen in the fuel pick up inside the tank? Have you checked the filter in the fuel pump?
08-04-2012 10:49 PM
Stu Jackson
Re: Westerbeke 30B Deceleration Stumble/Stalling

Have your removed the filter screen in the fuel pick up inside the tank? Have you checked the filter in the fuel pump?
08-04-2012 08:16 PM
lenkrauss
Re: Westerbeke 30B Deceleration Stumble/Stalling

Okay, the decel stumble problem was solved by replacing two governor springs and a fuel rod (governor linkage to IP rack). I think the culprit was actually just one spring that was weak. It was an idle speed set spring. It sets the throttle (IP rack) linkage to idle rpm when throttle is in neutral and when engine is not running. Doing this job on this engine is a nightmare because the governor is built into the front engine cover and it has to be removed. (As opposed being able to remove just the governor.)

Now there's a NEW PROBLEM that didn't exist before the IP and injectors were rebuilt. The engine fails to achieve WOT 3600 rpm under load as it always did before. Now it's like 2800 rpm, a 22% loss in power. As with the previous problem, everything we could think of was done to rule out various other causes before pulling the IP and taking it back to the rebuilder for retesting on his IP machine. It checks out as delivering fuel volume per spec. The IP is a Denso PFR3 #094500-4510 11S. Per rebuilder the replacement Elements used are Denso# 36 090150-4280

Seems to me that the IP is not delivering enough fuel at WOT -- engine seems fuel starved. The IP rack moves to its max throw -- my mechanic disconnected linkage rod to governor and operated the rack by hand for load testing. Also, a test was done with fresh fuel in jug piped directly to IP (using a external small lift pump and inline filter) and a new return line back to the jug -- thus, my boat's fuel system was totally eliminated. The boat bottom is clean and visible saildrive prop in excellent condition.

The engine has 700 hours. It starts easily and runs fine. There's no smoke of any kind and no oil sheen on water by the exhaust. Oil pressure and engine temperature are normal. There's no air filter (only a visible screen) and no air cut off.

I'm a a dead end here. Any ideas would be much appreciated.
03-21-2012 01:46 PM
lenkrauss
Re: Westerbeke 30B Deceleration Stumble/Stalling

Thanks. I did set the idle up some from spec, but causes a bad transmission slam when shifting gears and really didn't help. For a picture of the injector pump that you requested, the best I can do is ask you to download the Tech Manual. The pump is on page 58. There's also other info in the manual that may be helpful.

westerbeke, marine generators, engines, Official Site
03-20-2012 02:47 PM
dieselboy
Re: Westerbeke 30B Deceleration Stumble/Stalling

You just need to idle the engine up a bit. Its set to close to fuel shut off.
The fuel pump shop should of put that pump on a pump stand and ran it. If that was done then it should not shut down like that.
When the pump is down throttled it should return to low idle and stay there. It sounds as if it drops below fuel cut. Rather than taking it back to the fuel shop it can be reset there on the boat. put a pic of fuel inj pump up and i will point out what to do for you.
03-19-2012 10:51 AM
lenkrauss
Re: Westerbeke 30B Deceleration Stumble/Stalling

Have removed throttle cable from the governor bell-crank lever to which it attaches and operated it by hand. That lever has adjustable stop screws for both idle and high RPM. Each is fitted with jam nut so they don't vibrate out of adjustment.

Inside the governor there is something called a "start spring." When the engine's not running, it sets the fuel rack in position to supply fuel at idle RPM with the throttle in neutral. That seems to work. Yes, there are glow plugs. In starting, there's a pushbutton that must first be pressed and held for 10 seconds or so before then also pressing the button that cranks the engine. That first button activates the glow plugs and lift pump. That all works just fine.

Nothing about the engine's smoothness in running or noise level seems any different that it always been.
03-19-2012 07:11 AM
Gladrags1
Westerbeke 30B Deceleration Stumble/Stalling

I think that looking at cable movement and run for the throttle has merit as well. There should be adjustments you can make on the length of travel? Does your diesel have glow plugs? Still wondering what's different when the diesel first starts. Otherwise, the engine runs smoothly and quietly (as quietly as a diesel can) or does it seem louder than before the "runaway" event?
03-19-2012 12:18 AM
lenkrauss
Re: Westerbeke 30B Deceleration Stumble/Stalling

Thank you. Can't say that I disagree with your reasoning. Here's the thing: this engine runs perfectly in all respects except for the rapid decel stumble.
I'm thinking there's some kind of overshoot that causes fuel starvation, wherein some kind of linkage or lever moves past where it should and gets stuck. The governor is the master of where the fuel injector rack is permitted to be. All throttle activity goes through it. If the governor "decides" it doesn't like some attempted throttle action, it won't happen. But, as you note, why something would malfunction only when the engine's warmed up a little is the mystery.

Basically, nothing's adjustable in the governor. It has flyweights that move a shaft in and out. The shaftend contacts a spring-loaded lever. This and other lever and linkage movements are controlled by several springs within the governor. Everything is splash lubricated by engine oil. Of course these are all calibrated springs. But, it's hard to imagine they would be affected only when the engine is warm, causing the rapid decl stumble.

I'm still open to the possibility that the problem lies elsewhere.
03-18-2012 07:13 AM
Gladrags1
Re: Westerbeke 30B Deceleration Stumble/Stalling

I want to preface my comments by saying that I am no diesel mechanic. That said, you basically have a new engine there. The fact that this condition doesn't occur when the engine is cold but only occurs when up to operating temp makes me suspect that there is something in the fuel delivery / injection / timing area. If this were a gas powered engine, I would think about what effect having the choke on that made the engine run better. But it's diesel so things are different. The question here is why DOESN'T it happen when engine is cold. Fuel advance different? Air supply different? Throttle different? I would think if it is the governor, wouldn't it occur when engine is cold as well? I would think so. All that said, I wonder what damage might have been caused by the runaway engine. Did you conduct a compression test to see if all cylinders are equal in cast there was some damage to the inside of the cylinder.

Again, I don't profess to be an expert but I have a basic mechanical aptitude and present these thoughts to help consider likely options and hopefully not to confuse the issue. Good luck in solving the issue!
03-17-2012 07:27 PM
lenkrauss
Westerbeke 30B Deceleration Stumble/Stalling

Suspect that I have a governor problem and it's a lot of disassembly work to get at those parts to fully examine them. But, from what I can see with the top cover off, the governor parts all move and springs seem to work.

The engine has 600 hours and runs fine in every respect but one. I have a stumble/stall when rapidly decelerating from 2000+RPM to idle set at 1100RPM, with and without load. This happens only when the engine temp gets above 120 degs and then always happens. Injection pump and injectors have been professionally tested, serviced to spec and reinstalled -- no improvement. Boat's fuel delivery system has been eliminated as cause by isolation testing using a separate lift pump separately powered, inline filter, separate fuel supply and return lines to injector pump, (return line into bucket), and fresh fuel in a carry jug.

The engine was over-reved (runaway due to starting fluid) once and this may have affected the governor. I can't pinpoint when this problem began. It seems like there's an overshoot, causing fuel starvation, when the throttle is cut rapidly to idle. RPM drops to 500 range, engine stumbles badly, giving more throttle has no effect, sometimes recovers to idle on its own, sometimes stalls. Again, only when the engine is warmed up a little. . .not when cold, load and no-load.

Lab test of crankcase 15W-40 oil shows nothing unusual. Viscosity and everything else within spec.

What might cause this, other than a governor problem?

If the governor is the likely culprit, what governor parts are the main suspects for the problem I have?

Thanks.

 
Posting Rules
You may post new threads
You may post replies
You may post attachments
You may edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On


All times are GMT -4. The time now is 09:55 PM.

Add to My Yahoo!         
Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
SEO by vBSEO 3.6.1
(c) Marine.com LLC 2000-2012

The SailNet.com store is owned and operated by a company independent of the SailNet.com forum. You are now leaving the SailNet forum. Click OK to continue or Cancel to return to the SailNet forum.