SailNet Community - Reply to Topic

   Search Sailnet:

 forums  store  


Quick Menu
Forums           
Articles          
Galleries        
Boat Reviews  
Classifieds     
Search SailNet 
Boat Search (new)

Shop the
SailNet Store
Anchor Locker
Boatbuilding & Repair
Charts
Clothing
Electrical
Electronics
Engine
Hatches and Portlights
Interior And Galley
Maintenance
Marine Electronics
Navigation
Other Items
Plumbing and Pumps
Rigging
Safety
Sailing Hardware
Trailer & Watersports
Clearance Items

Advertise Here






Go Back   SailNet Community > Boat Builders Row > Pacific Seacraft > Universal M-50B "Feature" discovered
 Not a Member? 


Thread: Universal M-50B "Feature" discovered Reply to Thread
Title:
  

By choosing to post the reply below you agree to the rules you agreed to when joining Sailnet.
Click Here to view those rules.

Message:
Trackback:
Send Trackbacks to (Separate multiple URLs with spaces) :
Post Icons
You may choose an icon for your message from the following list:
 

Register Now

In order to be able to post messages on the SailNet Community forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
Please note: After entering 3 characters a list of Usernames already in use will appear and the list will disappear once a valid Username is entered.
User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Click here to view the posting rules you are bound to when clicking the
'Submit Reply' button below


Additional Options
Miscellaneous Options

Click here to view the posting rules you are bound to when clicking the
'Submit Reply' button below


Topic Review (Newest First)
07-12-2012 02:31 PM
teejayevans
Re: Universal M-50B "Feature" discovered

FYI,
I run the oil switch to a relay, just to lesson the draw on the small wires to the ignition switch from the fuel pump, also I added a bypass switch which I used for bleeding or if I haven't started the engine in a while, I run the elec pump for 15-30 secs until it is pumping normally (1 click every second), then turn it off and start the engine normally, this seems to help get quicker starts after long layoffs. I could also use it to polish the fuel or bypass the oil pressure switch. Easy to install and very handy to have.
Tom
07-10-2012 10:07 PM
BirdBrain333
Universal M-50B "Feature" discovered

Dear folks,

Not sure how many have a Universal Diesel in their PSCs but thought I would relate this discovery of a barely documented "feature" of the M-50 B engines.

The Story: Day 1, Started the engine. Engine alarm continued after the engine started but oil pressure, temperature, and charging were all normal. Accelerated slightly and alarm shut off, no further problems.

Day 3. Started engine, alarm again stayed on, accelerating did not "fix" it. Because oil pressure, charge, and water temp were all normal I figured it was a sensor and proceeded to motor from our mooring to the dock. About 500 yards off the mooring the engine slowed, slowed some more, and died. We drifted onto an empty mooring and scratched heads. Plenty of fuel and no water or gunk from draining the Racor. Hmmm. Prepare to start engine and lift pump ticks loudly for much longer than usual (15 versus 7 seconds) before going into its quite ticking. Hmmm. Engine starts, runs for a while, then slows and dies. Repeat. Each time with engine alarm beeping continuously while the engine is running despite good oil pressure, temperature, and charging.

OK, the punch line. In addition to an oil pressure sensor there is also on this engine an oil pressure switch (two wires) which is wired into the lift pump. If the oil pressure switch senses low oil pressure it shuts off electricity to the lift pump. The engine then runs on whatever is available in the lift pump, slows and dies thereby saving your engine.

But the real punch line is that this feature is nowhere mentioned in the Operators Manual or Service Guide. Reading the wiring diagram is the only clue. Fortunately a friendly diesel mechanic knew from the symptoms I described exactly what it was and thus I discovered the existence of a previously unknown part of my engine! I'll now carry a spare! But I sure do wonder if I'm the only one who did not know about this "feature??"

Enjoying summer, Jay

PSC 37, Kenlanu
Buck's Harbor, ME

 
Posting Rules
You may post new threads
You may post replies
You may post attachments
You may edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On


All times are GMT -4. The time now is 06:54 AM.

Add to My Yahoo!         
Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
SEO by vBSEO 3.6.1
(c) Marine.com LLC 2000-2012

The SailNet.com store is owned and operated by a company independent of the SailNet.com forum. You are now leaving the SailNet forum. Click OK to continue or Cancel to return to the SailNet forum.