SailNet Community - Reply to Topic

   Search Sailnet:

 forums  store  


Quick Menu
Forums           
Articles          
Galleries        
Boat Reviews  
Classifieds     
Search SailNet 
Boat Search (new)

Shop the
SailNet Store
Anchor Locker
Boatbuilding & Repair
Charts
Clothing
Electrical
Electronics
Engine
Hatches and Portlights
Interior And Galley
Maintenance
Marine Electronics
Navigation
Other Items
Plumbing and Pumps
Rigging
Safety
Sailing Hardware
Trailer & Watersports
Clearance Items

Advertise Here






Go Back   SailNet Community > On Board > Gear & Maintenance > Electrical Systems > balmar mc612 equalizing issues
 Not a Member? 


Thread: balmar mc612 equalizing issues Reply to Thread
Title:
  

By choosing to post the reply below you agree to the rules you agreed to when joining Sailnet.
Click Here to view those rules.

Message:
Trackback:
Send Trackbacks to (Separate multiple URLs with spaces) :
Post Icons
You may choose an icon for your message from the following list:
 

Register Now

In order to be able to post messages on the SailNet Community forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
Please note: After entering 3 characters a list of Usernames already in use will appear and the list will disappear once a valid Username is entered.
User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Click here to view the posting rules you are bound to when clicking the
'Submit Reply' button below


Additional Options
Miscellaneous Options

Click here to view the posting rules you are bound to when clicking the
'Submit Reply' button below


Topic Review (Newest First)
12-20-2012 10:01 PM
Maine Sail
Re: balmar mc612 equalizing issues

Your batteries were simply not full. This is very, very typical of alternator charging and improper programming of the regulators... Please do not try to equalize batteries with an alternator regulator.... Save this for dock side...

Why?

* Fully charging batteries, to the point where you can equalize them, will take 10+ hours of engine run time unless you have Odyssey TTPL (which can't be equalized anyway) or LiFePO4 (which don't need EQ).

*It requires a properly programmed regulator. 98.5% of the regs I see out there are not properly programmed and are simply using the factory pre-sets. These factory pre-set programs WILL NOT fully charge a typical house battery bank as they go into float mode far to early. At float voltages and "premature floatulation" it can take days not hours to fully charge the bank..

*On top of running your engine for 10+ hours (with a properly programmed regulator) you will then need a minimum of 2 to 4+ hours of lightly loaded engine run time, preferably with no changes in RPM, in order to do a proper EQ cycle, If you then check SG and find a cell still out of balance another 2-4 hours may be necessary.. The last 4-5 hours of the initial charging will also be "lightly loaded" due to acceptance.

*Add all this up and you're looking at 14 - 18 hours of running the engine to do an EQ cycle with a regulator. If doing a large crossing this can be one thing but of course you will want to ideally turn off any electrical devices not rated for 16V, when doing an EQ, so as not to over voltage them. To do this on the hook somewhere is not the best solution and 24 hours of transient dock space would be less costly in the long run.

*The cost of fuel, wear & tear on the engine, alternator, belts etc. etc. all add up to far greater than one would imagine.

I would only ever do an EQ cycle in a real "pinch" and even then I suspect I would hold off until there was an opportunity to do it connected to shore power or via a charger and gen set.

Before and EQ cycle you need to charge the bank until you see 1.0% - 0.5% acceptance at 14.4V (NOT float voltage) before you can even consider an EQ cycle. With many shore chargers this involves unplugging it to get it to reset back into a second round of absorption to fully top the batteries up. Many "smart chargers" are not quite as "smart" as we think they are and have "timed" absorption cycles that may not at all be geared for the bank you have on your boat. These absorption cycle durations, like the factory pre-set regulator profiles, are "generally safe" but do not always charge well or hold the batteries in absorption long enough.. Until your current is 1% or less at 14.4V then you're not ready to EQ.. A truly full battery will actually take less than .5% at 14.4V....

When you do bump the voltage to 15.5V you will see the current go up but it should not be much more than 2-4% of "C".. The best way to EQ batteries is with a lab grade bench top power supply as they allow you to control both current and voltage... The worst ways are alternator followed by solar....

Any EQ cycle should also be temp compensated whether with a shore charger or an alternator or solar system. If you can't guarantee the bank is at 77F during the EQ cycle you risk damaging the bank. I have seen people DESTROY batteries in engine compartments doing an EQ cycle with an alternator regulator that lacked temp compensation. Engine rooms are a HORRIBLE place for batteries but that's an entirely different discussion. As battery temp increases the battery voltage must be compensated and decrease especially when pushing EQ voltages.
12-20-2012 09:42 PM
sailalibi
balmar mc612 equalizing issues

When I had fully charged my batteries (under way) and verified that my 612 shows a charge stage of 510 I tried to equalize. After programming the regulator for equalizing and starting it my link 2000 showed that I was pumping in about 30 amps or so at 15 volts and rising. My understanding is that you should only equalize at around 4 percent of battery capacity (in my case only about 15 amps). What am I missing here? I tried to amp down (AP mode at about 130) to lower the amps but this choked down the voltage. Is my regulator bad?

 
Posting Rules
You may post new threads
You may post replies
You may post attachments
You may edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On


All times are GMT -4. The time now is 05:55 AM.

Add to My Yahoo!         
Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
SEO by vBSEO 3.6.1
(c) Marine.com LLC 2000-2012

The SailNet.com store is owned and operated by a company independent of the SailNet.com forum. You are now leaving the SailNet forum. Click OK to continue or Cancel to return to the SailNet forum.