SailNet Community - Reply to Topic

   Search Sailnet:

 forums  store  


Quick Menu
Forums           
Articles          
Galleries        
Boat Reviews  
Classifieds     
Search SailNet 
Boat Search (new)

Shop the
SailNet Store
Anchor Locker
Boatbuilding & Repair
Charts
Clothing
Electrical
Electronics
Engine
Hatches and Portlights
Interior And Galley
Maintenance
Marine Electronics
Navigation
Other Items
Plumbing and Pumps
Rigging
Safety
Sailing Hardware
Trailer & Watersports
Clearance Items

Advertise Here






Go Back   SailNet Community > On Board > Gear & Maintenance > broken westerbeke engine mounts in 331
 Not a Member? 


Thread: broken westerbeke engine mounts in 331 Reply to Thread
Title:
  

By choosing to post the reply below you agree to the rules you agreed to when joining Sailnet.
Click Here to view those rules.

Message:
Trackback:
Send Trackbacks to (Separate multiple URLs with spaces) :
Post Icons
You may choose an icon for your message from the following list:
 

Register Now

In order to be able to post messages on the SailNet Community forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
Please note: After entering 3 characters a list of Usernames already in use will appear and the list will disappear once a valid Username is entered.
User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Click here to view the posting rules you are bound to when clicking the
'Submit Reply' button below


Additional Options
Miscellaneous Options

Click here to view the posting rules you are bound to when clicking the
'Submit Reply' button below


Topic Review (Newest First)
01-29-2013 02:45 PM
nmejicano
Re: broken westerbeke engine mounts in 331

I just found a rear starboard side mount broken (at least one of the bolts). I have a 2004 Westerbeke B3 and as soon as I haul out in three weeks I wilkl replace all four since the other three are pretty much rusted. The replacement mounts from Westerbeke are over $200.00 each! I found a company, Torresen Marine, Inc which makes mounts for this engine for $48.00! You also can see how to change them through a great video that you will find at: www.pbase.com/mainecruising/motor_mounts. Good luck. By the way it is better to rep[lace all four instead of just one if they are more than two-three years old.
08-30-2010 10:46 AM
finney
broken westerbeke engine mounts in 331

Hi all we have a Westerbeke 30b in our 331. Last year while traveling the front port side monting bolts broke off where the attach the leg bracket to the front of the eng. Did the repair had the allignment checked and started a new year. This year the leg on the same side broke where the bend it to match it to the front of the engine. Westerbeke has been NO help and treated me like dirt because its out of warranty coverage. ( The folks at Mack Boring Yanmar were much nicer and offered a lot of suggestions great place.)

Has anyone out there had simular problems? the yard wants to make a steel bridge and weld the two front mounts together. I'm not sure if that won't jsut transfer what ever force is causing the problem to send its energy to a new place and cause more problems. Westerbeke has redesigned the mounts with a gussett welded behind the point where mine broke which leads me to think they knew it was weak. Any thought would be welcome hope to find anyone with the same problem to talk over the issue

 
Posting Rules
You may post new threads
You may post replies
You may post attachments
You may edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On


All times are GMT -4. The time now is 10:52 PM.

Add to My Yahoo!         
Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
SEO by vBSEO 3.6.1
(c) Marine.com LLC 2000-2012

The SailNet.com store is owned and operated by a company independent of the SailNet.com forum. You are now leaving the SailNet forum. Click OK to continue or Cancel to return to the SailNet forum.