Justin's Catalina 25: Installed table and a few other things @ Sail Blogs - SailNet Community
LinkBack Article Tools
Justin's Catalina 25: Installed table and a few other things @ Sail Blogs
by NewsReader 04-10-2006

I got a few things done out on the boat today. I did some more tests with my outboard to figure out if it is connected properly since the starter still does not work. It is in fact connected properly and I was able to test the voltage on the power lead a few feet from the outboard. I measured over 12 volts and let it run for 15 minutes and the alternator charged the battery to over 13 volts, so now I know that works. The fuse is good on the outboard, so I need to figure out why the starter still isn't working. Dave and I are going to look into it some more probably this coming weekend. Direct Link


Link To Original Article
Reply With Quote Quick reply to this message
Share with Facebook
Views 542 Comments 0
Total Comments 0



Quick Reply

By choosing to post the reply above you agree to the rules you agreed to when joining Sailnet.
Click Here to view those rules.

Register Now

In order to be able to post messages on the SailNet Community forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
Please note: After entering 3 characters a list of Usernames already in use will appear and the list will disappear once a valid Username is entered.

User Name:
Please enter a password for your user account. Note that passwords are case-sensitive.


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:


Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.

Currently Active Users Viewing This Article: 1 (0 members and 1 guests)
Article Tools
Show Printable Version Show Printable Version
Email this Page Email this Page

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On
Trackbacks are On
Pingbacks are On
Refbacks are On

For the best viewing experience please update your browser to Google Chrome